Issue 11860

Summary: New option at paragraph to adjust spacing implementation for object positioning - compatibility to MS Word
Product: Writer Reporter: Oliver-Rainer Wittmann <orw>
Component: uiAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: caolanm, issues, michael.brauer
Version: 644Keywords: ms_interoperability
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation on: ---
Developer Difficulty: ---
Issue Depends on: 25470    
Issue Blocks: 4357, 14695    

Description Oliver-Rainer Wittmann 2003-02-26 16:01:50 UTC
As figured out in issue #4357#, we need a new option at the paragraph to control
the spacing implementation.
In the current writer implementation the lower spacing of a paragraph is hold by
the following paragraph. This causes problems in our compatibility to MS Word in
the positioning of objects anchored at the paragraph.
E.g.: An rectangle in MS Word, anchored at a paragraph with no upper spacing,
relative positioned 1cm below top of paragraph, will in writer have another
relative position depending on the lower spacing of the previous paragraph.
Thus, for compatibility reasons such a new option would be useful. But - and
it's a BIG but -, this option makes only sense, if the global document option
'add spacing between paragraph and tables in the current document' - see
Tools-Options-Text Document-General - is switched on.
OD->FT: As I known You takes care of our compatibilty to MS Word, I assigned
this issue to You.
Comment 1 Oliver-Rainer Wittmann 2003-02-26 16:02:30 UTC
OD (26.02.2003): set appropriate target.
Comment 2 caolanm 2003-04-09 16:42:02 UTC
Added keyword.
Comment 3 Oliver-Rainer Wittmann 2003-07-07 13:11:52 UTC
OD (07.07.2003):
Take over for verifying target and priority.
Comment 4 Oliver-Rainer Wittmann 2003-07-07 13:18:41 UTC
.
Comment 5 Oliver-Rainer Wittmann 2003-08-14 12:51:21 UTC
OD (14.08.2003): accepted.
Comment 6 Oliver-Rainer Wittmann 2003-09-16 09:59:34 UTC
*** Issue 5797 has been marked as a duplicate of this issue. ***
Comment 7 Oliver-Rainer Wittmann 2003-09-24 09:51:46 UTC
.
Comment 8 Oliver-Rainer Wittmann 2004-02-13 14:25:36 UTC
specification for this enhancement could be found at
http://specs.openoffice.org/writer/compatibility/adjust-object-positioning.sxw
Comment 9 Oliver-Rainer Wittmann 2004-03-18 12:57:06 UTC
implementation of new enhancement finished in cws swobjpos05
Comment 10 Oliver-Rainer Wittmann 2004-03-19 13:19:52 UTC
OD->MRU:
Check in internal installation set of cws swobjpos05 - please verify.
Comment 11 michael.ruess 2004-03-31 13:39:40 UTC
Checked in CWS swobjpos05.
Comment 12 michael.ruess 2004-03-31 13:40:18 UTC
Verified.
Comment 13 michael.ruess 2004-04-27 12:12:27 UTC
Closed. Will be in OO 2.0.