Issue 103593

Summary: make insert menu behavior selection dependent
Product: General Reporter: hardy314 <hartmut.gimpel>
Component: chartAssignee: sgautier.ooo
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: IngridvdM, issues, kpalagin, thomas.klarhoefer
Version: OOo 3.3 or olderKeywords: usability
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation on: ---
Developer Difficulty: ---
Attachments:
Description Flags
File for faster repro.
none
TCS Chart Menu Selection Dependent none

Description hardy314 2009-07-16 19:25:18 UTC
Here is how to reproduce the malbehavior:

1. create a new spreadsheet in Calc (happened with OO3.1.0)

2. insert two rows of data, as well as to rows for error bar data, e.g.:
   x     y1     y2    erry1    erry2
   1     2      5       1        2
   2     2      5       1        2

3. mark the first three rows and create an xy plot diagram -> works fine so far.

4. now mark only the first plotted line (generated from the y1 data) in the
diagram and use the menu command "insert - Yerrorbar" and select only the data
of the column "erry1" for symmetric error bars from cell data.

5. result: these error bar values are used by OO to generate error bars on BOTH
plotted lines. (This is already wrong behavior, but could probably be tolerated.)

6. Now, explicitly select the second line in the plot (generated from the y2
data) and try to add different error bars (with the erry2 values) using the same
commands as above.

7. result: now the erry2 values are used for BOTH plots (for the y1 and for the
y2 line). At this point the frustration of the user definitly explodes! It seems
to be impossible to generate plots with two lines that have INDEPENDENT error
bar data.

To be honest, I eventually did find a workaround to still use OO Calc to
generate the expected plot with two independent error bar'ed lines (via first
doubly clicking and then right clicking on the wrongly plotted error bars
themselves and then use "object properties" and change the targeted cell area).
But this is a totally complex procedure that hardly any other user will find by
chance :(

Since the occurance of plots with error bars in combination with plots with more
then one data line is not uncommon at all in the sciences as well as in
medicine, I consider this a significant malfunction, hence a P3. 

Additionally, it is a pity. OO CAN do these plots, just some internal function
calls seem to be connected wrongly in the code. So go ahead, do the small change
and let OO show what I already can do! :)
Comment 1 hardy314 2009-07-16 19:30:47 UTC
sorry, this seems to be a chart issue, changed it.
Comment 2 kpalagin 2009-07-20 12:05:50 UTC
Confirming with m51 on WinXP - as described.
Comment 3 kpalagin 2009-07-20 12:07:22 UTC
Created attachment 63643 [details]
File for faster repro.
Comment 4 oc 2009-07-20 13:22:21 UTC
reassigned to chartowner
Comment 5 kla 2009-07-20 13:39:07 UTC
Hi Iha,
one for you.
kla
Comment 6 IngridvdM 2009-08-07 15:16:42 UTC
In CWS chartuseability I now made the behavior of the Insert menu selection
dependent.
In case a single data series is selected or an element belonging to a single
data series the error bars are inserted only for this single series. Otherwise
the error bars are inserted for all existing series. The upcoming dialogs now
reflect this difference within their title. The new strings are defined in
http://specs.openoffice.org/chart/ChartObjectNames.odt.
So the title of the dialog to change the error bar properties is 'Error Bars for
Data Series 'ABC'' in case the series was selected. Otherwise the title is
'Error Bars for all Data Series'.

To be consistent this change in behavior also affects the other three menu items
in the same section:
Insert -> Data Labes...
Insert -> Trend Lines ...
Insert -> Mean Value Line.

For more details look at the specification:
http://specs.openoffice.org/chart/ChartMenu.odt
Comment 7 IngridvdM 2009-08-07 15:49:36 UTC
Created issue 104086 to adapt the test scripts and issue 104087 to adapt the
documentation.
Comment 8 hardy314 2009-08-08 09:15:30 UTC
Thanks for fixing this! I'm looking forward to seeing this live in OO3.2 :)
Comment 9 IngridvdM 2009-08-26 12:51:38 UTC
Sophie, please verify in CWS chartuseability01 that the following four menu
entries in the insert menu now work selection dependent:
Insert -> Data Labes...
Insert -> Trend Lines ...
Insert -> Mean Value Lines
Insert -> Y Error Bars...
In case a single data series is selected (or an element belonging to a single
data series) the additional elements should be inserted only for this single
series. Otherwise they should be added to all existing series.
Thanks! Ingrid
Comment 10 sgautier.ooo 2009-08-31 17:17:52 UTC
Verified in CWS chartuseability01. The entries are present and insert the
additional elements for only a data series or a single point in the data series
that is selected, or for all data series instead - Sophie
Comment 11 sgautier.ooo 2009-09-08 15:17:19 UTC
Attaching TCS Chart Menu Selection Dependent - Sophie
Comment 12 sgautier.ooo 2009-09-08 15:18:06 UTC
Created attachment 64614 [details]
TCS Chart Menu Selection Dependent
Comment 13 sgautier.ooo 2009-10-22 16:54:07 UTC
Verified in OOO320m2 - Closing - Sophie