Issue 101690

Summary: Sort in CALC mixes up references to cell identifiers
Product: Calc Reporter: patb <patb>
Component: programmingAssignee: oc
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: dmartina, ejubin, issues, jbf.faure, kpalagin, oliver.brinzing, ooo
Version: OOO310m11Keywords: oooqa
Target Milestone: ---   
Hardware: Unknown   
OS: All   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 101565    
Attachments:
Description Flags
ssue 101690 - Sort in CALC mixes up references to cell identifiers none

Description patb 2009-05-08 16:29:25 UTC
OOO310m11 

I'm bringing forward a spreadsheet from Calc Open Office 3.01 into Open Office
3.1 that I downloaded last night and updating my personal accounts for last few
days. 
Column A is date. Other columns have references in them. References are like in
cell BeforeSort.F11 have =ROUND(0.05*E11;2) and E11 is a reference. Sort by
date, column A, and find that references are all screwed up. Some are sorted as
expected - for example cell AfterSort.G10. 

Some are messed up - for example AfterSort.F10 is  =ROUND(0.05*E11;2) -
AfterSort.F10 should be =ROUND(0.05*E10;2)

Another example Aftersort.N11 = =IF(LEFT($C7;3)="rec";$I7;0)

I think you get the idea. I'll send the spreadsheet in email since only use this
occasionally and don't see where to paste it.
Comment 1 patb 2009-05-08 16:33:46 UTC
Created attachment 62103 [details]
ssue 101690 - Sort in CALC mixes up references to cell identifiers
Comment 2 niklas.nebel 2009-05-11 16:56:20 UTC
taking the issue
Comment 3 niklas.nebel 2009-05-11 17:02:28 UTC
Fixed in CWS "calc50".
Comment 4 niklas.nebel 2009-05-12 09:40:00 UTC
*** Issue 101791 has been marked as a duplicate of this issue. ***
Comment 5 niklas.nebel 2009-05-12 11:27:59 UTC
*** Issue 101653 has been marked as a duplicate of this issue. ***
Comment 6 brinzing 2009-05-12 17:29:47 UTC
adding me to cc
Comment 7 kpalagin 2009-05-13 08:29:20 UTC
Please consider targeting this issue for 3.1.1.
Comment 8 niklas.nebel 2009-05-13 17:17:36 UTC
*** Issue 101845 has been marked as a duplicate of this issue. ***
Comment 9 niklas.nebel 2009-05-13 17:50:21 UTC
Also in CWS "calc311fixes" for 3.1.1.
Comment 10 dhmartin 2009-05-15 13:28:34 UTC
I'm not sure if it has to do with references. If it were just formulas it would
be easy to copy down the whole column. I have references in a column, but even
the rest of the columns with static strings get mixed (data from a single row is
randomly spread in different rows). Data gets completely messed so I have to
recover my backups. Quite disgusting!
Comment 11 niklas.nebel 2009-05-15 13:34:10 UTC
dhmartin, that would be a different issue. Can you provide an example file?
Comment 12 dhmartin 2009-05-15 13:37:21 UTC
Let my try this evening. It's quite a large file and I'll try to short it down.
Comment 13 dhmartin 2009-05-15 17:31:35 UTC
Hmmm, not so bad. I carefully rebuilt the column with the formulas and nearly
everything seemed very better. There were a couple of errors in the original
data that were confusing my fear! ;-) Sorry for the alarm. Anyway, I'll keep an
eye (even two or three) on the file, just I case...
Comment 14 Regina Henschel 2009-05-19 20:00:54 UTC
*** Issue 102065 has been marked as a duplicate of this issue. ***
Comment 15 niklas.nebel 2009-05-25 17:19:30 UTC
*** Issue 102225 has been marked as a duplicate of this issue. ***
Comment 16 niklas.nebel 2009-05-26 18:56:20 UTC
reassigning to QA for verification
Comment 17 Regina Henschel 2009-06-02 00:59:31 UTC
*** Issue 102416 has been marked as a duplicate of this issue. ***
Comment 18 oc 2009-06-03 07:36:29 UTC
verified in internal build cws_calc311fixes (OOo311) and
verified in internal build cws_calc50 (OOo32)
Comment 19 niklas.nebel 2009-06-09 08:49:06 UTC
*** Issue 102600 has been marked as a duplicate of this issue. ***
Comment 20 niklas.nebel 2009-06-11 13:10:27 UTC
*** Issue 102668 has been marked as a duplicate of this issue. ***
Comment 21 Regina Henschel 2009-06-12 23:06:07 UTC
*** Issue 102717 has been marked as a duplicate of this issue. ***
Comment 22 niklas.nebel 2009-06-22 17:07:37 UTC
*** Issue 102997 has been marked as a duplicate of this issue. ***
Comment 23 wope 2009-06-24 02:19:08 UTC
*** Issue 103043 has been marked as a duplicate of this issue. ***
Comment 24 wope 2009-06-24 02:20:08 UTC
*** Issue 103043 has been marked as a duplicate of this issue. ***
Comment 25 Regina Henschel 2009-07-04 14:04:21 UTC
*** Issue 103324 has been marked as a duplicate of this issue. ***
Comment 26 Rainer Bielefeld 2009-07-19 10:05:19 UTC
*** Issue 103615 has been marked as a duplicate of this issue. ***
Comment 27 kpalagin 2009-07-20 13:00:05 UTC
*** Issue 103567 has been marked as a duplicate of this issue. ***
Comment 28 kpalagin 2009-07-21 09:19:32 UTC
*** Issue 103419 has been marked as a duplicate of this issue. ***
Comment 29 oc 2009-08-06 07:52:25 UTC
*** Issue 104038 has been marked as a duplicate of this issue. ***
Comment 30 Rainer Bielefeld 2009-08-07 06:51:12 UTC
This issue is not VISTA specific!
Comment 31 Rainer Bielefeld 2009-08-07 06:52:20 UTC
*** Issue 104067 has been marked as a duplicate of this issue. ***
Comment 32 Rainer Bielefeld 2009-08-09 11:59:31 UTC
*** Issue 104112 has been marked as a duplicate of this issue. ***
Comment 33 jbf.faure 2009-08-17 21:07:05 UTC
*** Issue 104288 has been marked as a duplicate of this issue. ***
Comment 34 ooo 2009-08-23 19:58:53 UTC
Ok in OOo 3.1.1 rc2 OOO310m19
closing.
Comment 35 ooo 2009-09-01 12:33:30 UTC
*** Issue 104657 has been marked as a duplicate of this issue. ***
Comment 36 Regina Henschel 2009-10-04 18:04:47 UTC
*** Issue 105588 has been marked as a duplicate of this issue. ***
Comment 37 jhayward72 2009-10-18 23:56:07 UTC
I am having a similar problem to this and other I have seen. When trying to 
sort cell references, the references get corrupted completely.  I just upgraded 
to 3.1.1 with no change in the results. Sorting the same file in Excel works 
without problem.
Comment 38 ooo 2009-10-19 06:46:37 UTC
jhayward72, so you are saying this bug still exists in 3.1.1?

Could you please attach a sample document and a description what steps are
needed to reproduce it?
Comment 39 patb 2010-01-09 15:18:00 UTC
I just tried out my original example in version 3.2.0 and it works OK there.
Thanks for fixing this! BTW, I've been using version 3.0.0 for any important
spreadsheets.