Issue 10101

Summary: Impress drops imags when many/large images have been inserted
Product: Impress Reporter: thorwil <thorwil>
Component: codeAssignee: christian.guenther
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: faught, issues, lohmaier, pavel
Version: OOo 1.1Keywords: oooqa
Target Milestone: ---   
Hardware: PC   
OS: Linux   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---
Attachments:
Description Flags
single impress page from which one image is missing
none
Impress (sxi) file - drops images in slides 5,8,11,13,14 none

Description thorwil 2002-12-16 11:26:51 UTC
Impress drops random images when many/large images have been inserted. Leaves
just empty frames. Images disappear after saving or printing. Sometimes an image
can be reinserted and stays, sometimes it will be droped again and again.
Comment 1 wolframgarten 2002-12-16 11:37:32 UTC
Set to new.
Comment 2 wolframgarten 2002-12-16 11:37:55 UTC
Reassigned to Christian.
Comment 3 faught 2003-01-02 20:03:40 UTC
Just saw this myself using OpenOffice 1.0.1 on Windows 2000, using a
100+ slide presentation.  Most slides don't have images except in the
background, but apparently there are enough to trigger this problem. 
This one is a showstopper for me.
Comment 4 dathomp1 2003-01-09 22:42:31 UTC
I've also seen this problem - the image format doesn't seem to matter
- jpegs, pngs, gifs have all vanished from my impress documents.
Comment 5 christian.guenther 2003-01-17 08:03:55 UTC
Please attach the document to reproduce the bug.
Comment 6 thorwil 2003-01-17 13:04:46 UTC
Created attachment 4326 [details]
single impress page from which one image is missing
Comment 7 thorwil 2003-01-17 13:11:23 UTC
My complete file was 44 MB. So I extracted a single page (see above).
Maybe its code gives a hint.

I can't reproduce the bug since I expanded my ram from 256 to 768 MB.
Maybe Impress can't deal with running low on memory? The file was very
heavy for my system but is quite handably now. So maybe a stress-test
with adding big images alot will show the bug. Could do that, but the
resulting file will be much too big for transfer.
Comment 8 dathomp1 2003-01-17 23:40:48 UTC
Created attachment 4335 [details]
Impress (sxi) file - drops images in slides 5,8,11,13,14
Comment 9 dathomp1 2003-01-17 23:44:49 UTC
The above file consistently drops images under Windows 98 w/96MB
memory.  I haven't tried it under Linux OpenOffice. This behavior
isn't limited to just this file but has popped up in other Impress
documents I've created.
Comment 10 christian.guenther 2003-01-28 11:54:03 UTC
change the target.
Comment 11 Unknown 2003-02-07 16:25:09 UTC
I recognized the same or similar behaviour. In my presentation OO 
Impress drops Graphics occasionally. Instead of the inserted picture 
on the Impress slide a puzzle element appears with the text 
SvOutPlaceObject in it.
If I click onto the puzzle element, a dotted frame appears with the 
size of the original picture (so Impress still knows about the 
element). But the picture is lost.
I'm not entirely shure but it only occurs with certain types of 
inserted picture - I believe it's bound to JPEG type pictures.
In some cases after save - close - reload of the presentation the 
picture is visible again - in some cases it is lost forever.
Again not sure but I suspect the problem of picture loss is bound to 
the switch between full slide edit view and slide sorter view. When 
switching to the latter, it always is the first time when the puzzle 
element(s) can occur.

Hope this helps
Jens
Comment 12 christian.guenther 2003-02-13 12:10:22 UTC
This is a known bug, which is fixed in the meantime. The fix will be
integrated in the OOo1.1Beta. Please test the bug again when the
OOo1.1Beta is available.
Comment 13 christian.guenther 2003-02-13 12:11:48 UTC
I close the issue.
Please reopen the issue when the bug still occures in the OOo1.1Beta.
Comment 14 stryder 2004-01-07 14:48:31 UTC
I am running 1.1.0 release on three different machines and have been burned by 
the images disapearing after saving the document several times on each machine.
Comment 15 christian.guenther 2004-01-08 08:46:35 UTC
There are two new known bugs about loosing graphics.
- The Temp folder is nearly full while saving the document. We are
working on this bug and it will be fixed soon. The Temp is the folder which is
set in 'Tools/Options/OpenOffice.org/Paths/Temporary files'. Normaly it is '/tmp'
-> Workaround: delete some files from te Temp folder so that tmp has
enough space.
- graphics disappears when the file is password protected. This bug is
fixed in the meantime. The fix will be integrated in OOo1.1.1
-> Workaround: use save as instead of save and make sure that 'Save
with password' is deselected.
Comment 16 lohmaier 2004-01-08 18:15:29 UTC
for reference, the password-thing is handled in issue 16297
Comment 17 lohmaier 2004-01-08 18:17:29 UTC
*** Issue 22763 has been marked as a duplicate of this issue. ***
Comment 18 lohmaier 2004-01-08 18:19:15 UTC
*** Issue 22310 has been marked as a duplicate of this issue. ***
Comment 19 lohmaier 2004-01-08 18:21:51 UTC
*** Issue 22823 has been marked as a duplicate of this issue. ***
Comment 20 christian.guenther 2004-01-29 16:32:09 UTC
set to fixed
Comment 21 christian.guenther 2004-01-29 16:33:43 UTC
The fix is integrated in OOo1.1.1 in Sols, Lin, Win.
OOo1.1.1 will be available soon.
Please reopen the issue if the bug still occures in OOo1.1.1
Comment 22 strube 2005-06-21 13:39:28 UTC
In StarOffice 7 Update 4 (Solaris SPARC, Patch 116519-06; afaIk corresponding to
OO 1.1.4), I still encountered this issue, although it was said to be fixed with
Patch 116519-03. Besides images, once also a math equation was dropped when
adding images. I reverted to StarOffice 6.0, which worked flawlessly.