ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-984

jenkins failure in testSessionMoved - NPE in quorum

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.3.2
    • Fix Version/s: 3.5.0
    • Component/s: None
    • Labels:
      None

      Description

      Got the following NPE on my internal jenkins setup running against released 3.3.2 (see attached log)

          [junit] 2011-02-06 10:39:56,988 - WARN  [QuorumPeer:/0.0.0.0:11365:Follower@116] - Got zxid 0x100000001 expected 0x1
          [junit] 2011-02-06 10:39:56,988 - INFO  [SyncThread:3:FileTxnLog@197] - Creating new log file: log.100000001
          [junit] 2011-02-06 10:39:56,989 - WARN  [QuorumPeer:/0.0.0.0:11364:Follower@116] - Got zxid 0x100000001 expected 0x1
          [junit] 2011-02-06 10:39:56,989 - INFO  [SyncThread:2:FileTxnLog@197] - Creating new log file: log.100000001
          [junit] 2011-02-06 10:39:56,990 - WARN  [QuorumPeer:/0.0.0.0:11363:Follower@116] - Got zxid 0x100000001 expected 0x1
          [junit] 2011-02-06 10:39:56,990 - INFO  [SyncThread:5:FileTxnLog@197] - Creating new log file: log.100000001
          [junit] 2011-02-06 10:39:56,990 - WARN  [QuorumPeer:/0.0.0.0:11366:Follower@116] - Got zxid 0x100000001 expected 0x1
          [junit] 2011-02-06 10:39:56,990 - INFO  [SyncThread:1:FileTxnLog@197] - Creating new log file: log.100000001
          [junit] 2011-02-06 10:39:56,991 - INFO  [SyncThread:4:FileTxnLog@197] - Creating new log file: log.100000001
          [junit] 2011-02-06 10:39:56,995 - INFO  [main-SendThread(localhost.localdomain:11363):ClientCnxn$SendThread@738] - Session establishment complete on server localhost.localdomain/127.0.0.1:11363, sessionid = 0x12dfc45e6dd0000, negotiated timeout = 30000
          [junit] 2011-02-06 10:39:56,996 - INFO  [CommitProcessor:1:NIOServerCnxn@1580] - Established session 0x12dfc45e6dd0000 with negotiated timeout 30000 for client /127.0.0.1:37810
          [junit] 2011-02-06 10:39:56,999 - INFO  [main:ZooKeeper@436] - Initiating client connection, connectString=127.0.0.1:11364 sessionTimeout=30000 watcher=org.apache.zookeeper.test.QuorumTest$5@248523a0 sessionId=85001345146093568 sessionPasswd=<hidden>
          [junit] 2011-02-06 10:39:57,000 - INFO  [main-SendThread():ClientCnxn$SendThread@1041] - Opening socket connection to server /127.0.0.1:11364
          [junit] 2011-02-06 10:39:57,000 - INFO  [NIOServerCxn.Factory:0.0.0.0/0.0.0.0:11364:NIOServerCnxn$Factory@251] - Accepted socket connection from /127.0.0.1:36682
          [junit] 2011-02-06 10:39:57,001 - INFO  [main-SendThread(localhost.localdomain:11364):ClientCnxn$SendThread@949] - Socket connection established to localhost.localdomain/127.0.0.1:11364, initiating session
          [junit] 2011-02-06 10:39:57,002 - INFO  [NIOServerCxn.Factory:0.0.0.0/0.0.0.0:11364:NIOServerCnxn@770] - Client attempting to renew session 0x12dfc45e6dd0000 at /127.0.0.1:36682
          [junit] 2011-02-06 10:39:57,002 - INFO  [NIOServerCxn.Factory:0.0.0.0/0.0.0.0:11364:Learner@95] - Revalidating client: 85001345146093568
          [junit] 2011-02-06 10:39:57,003 - INFO  [QuorumPeer:/0.0.0.0:11364:NIOServerCnxn@1580] - Established session 0x12dfc45e6dd0000 with negotiated timeout 30000 for client /127.0.0.1:36682
          [junit] 2011-02-06 10:39:57,004 - INFO  [main-SendThread(localhost.localdomain:11364):ClientCnxn$SendThread@738] - Session establishment complete on server localhost.localdomain/127.0.0.1:11364, sessionid = 0x12dfc45e6dd0000, negotiated timeout = 30000
          [junit] 2011-02-06 10:39:57,005 - WARN  [CommitProcessor:2:NIOServerCnxn@1524] - Unexpected exception. Destruction averted.
          [junit] java.lang.NullPointerException
          [junit] 	at org.apache.jute.BinaryOutputArchive.writeRecord(BinaryOutputArchive.java:123)
          [junit] 	at org.apache.zookeeper.proto.SetDataResponse.serialize(SetDataResponse.java:40)
          [junit] 	at org.apache.jute.BinaryOutputArchive.writeRecord(BinaryOutputArchive.java:123)
          [junit] 	at org.apache.zookeeper.server.NIOServerCnxn.sendResponse(NIOServerCnxn.java:1500)
          [junit] 	at org.apache.zookeeper.server.FinalRequestProcessor.processRequest(FinalRequestProcessor.java:367)
          [junit] 	at org.apache.zookeeper.server.quorum.CommitProcessor.run(CommitProcessor.java:73)
          [junit] Running org.apache.zookeeper.test.QuorumTest
          [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
          [junit] Test org.apache.zookeeper.test.QuorumTest FAILED (timeout)
          [junit] 2011-02-06 10:53:26,189 - INFO  [main:PortAssignment@31] - assigning port 11221
          [junit] 2011-02-06 10:53:26,192 - INFO  [main:PortAssignment@31] - assigning port 11222
      
      1. consoleText16.txt
        8.49 MB
        Patrick Hunt

        Activity

        Germán Blanco made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Germán Blanco added a comment -

        This was reported on a previous release (3.3.2), and as far as I know it hasn't been seen in a long time, so I believe it should be closed.

        some one added a comment -

        Is this still happening? If not, can you close the issue?

        Mahadev konar made changes -
        Fix Version/s 3.5.0 [ 12316644 ]
        Fix Version/s 3.4.0 [ 12314469 ]
        Benjamin Reed made changes -
        Fix Version/s 3.3.3 [ 12315482 ]
        Patrick Hunt made changes -
        Field Original Value New Value
        Attachment consoleText16.txt [ 12470480 ]
        Patrick Hunt added a comment -

        log of failured. search for FAILED

        Patrick Hunt created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Patrick Hunt
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development