Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-913

Version parser fails to parse "3.3.2-dev" from build.xml.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 3.3.1
    • Fix Version/s: 3.3.3, 3.4.0
    • Component/s: build
    • Labels:
      None

      Description

      Cannot build 3.3.1 from release tarball do to VerGen parser inability to parse "3.3.2-dev".

      version-info:
      [java] All version-related parameters must be valid integers!
      [java] Exception in thread "main" java.lang.NumberFormatException: For input string: "2-dev"
      [java] at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
      [java] at java.lang.Integer.parseInt(Integer.java:481)
      [java] at java.lang.Integer.parseInt(Integer.java:514)
      [java] at org.apache.zookeeper.version.util.VerGen.main(VerGen.java:131)
      [java] Java Result: 1

        Attachments

        1. zk-build.patch
          0.6 kB
          Anthony Urso
        2. zk-version.patch
          0.7 kB
          Anthony Urso
        3. ZOOKEEPER-913_br33.patch
          9 kB
          Patrick Hunt
        4. ZOOKEEPER-913.patch
          9 kB
          Patrick Hunt

          Activity

            People

            • Assignee:
              phunt Patrick Hunt
              Reporter:
              anthonyu Anthony Urso
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: