The SelectionKey class provides methods to replace something like this
(k.readyOps() & (SelectionKey.OP_READ | SelectionKey.OP_WRITE)) != 0
selectionKey.isReadable() || selectionKey.isWritable()
It may be possible, that the first version saves a CPU cycle or two, but the later version saves developer brain cycles which are much more expensive.
I suppose that there are many more places in the server code where this replacement could be done. I propose that whoever touches a code line like this should make the replacement.