Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.3.1
    • Fix Version/s: 3.4.0
    • Component/s: c client
    • Labels:
      None
    • Environment:

      Windows 7, 64-bit

      Description

      Use windows sockets and the win32 API for implementing the c client. This would be only useful for the "single-threaded" model, where the IO waiting is taken care of in the calling code.

      1. zk-win32-2010-08-31.patch
        7 kB
        Ben Collins
      2. config.h
        5 kB
        Ben Collins
      3. win32port.c
        0.4 kB
        Ben Collins

        Activity

        Mahadev konar added a comment -

        Duplicate of ZOOKEEPER-992.

        Ben Collins added a comment -

        The basic files for a new win32 port of the C API


          People

          • Assignee:
            Ben Collins
            Reporter:
            Ben Collins
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development