Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.3.1
    • Fix Version/s: 3.3.2, 3.4.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The pom deployed to repo1.maven.org has the project declared like this:

      <groupId>org.apache.zookeeper</groupId>
      <artifactId>zookeeper</artifactId>
      <packaging>jar</packaging>
      <version>3.3.1</version>

      But it is deployed here: http://repo2.maven.org/maven2/org/apache/hadoop/zookeeper/3.3.1

      So either the groupId needs to change or the location it is deployed to needs to be changed because having them different results in bad behavior. If you specify the correct groupId in your own pom/ivy files you can't even download zookeeper because it's not where your pom says it is and if you use the "incorrect" groupId then you can download zookeeper but then ivy complains about:

      [error] :: problems summary ::
      [error] :::: ERRORS
      [error] public: bad organisation found in http://repo1.maven.org/maven2/org/apache/hadoop/zookeeper/3.3.1/zookeeper-3.3.1.pom: expected='org.apache.hadoop' found='org.apache.zookeeper'

        Issue Links

          Activity

          Chris Conrad created issue -
          Hide
          Patrick Hunt added a comment -

          thanks for the heads up, marking as blocker for next rel.

          Show
          Patrick Hunt added a comment - thanks for the heads up, marking as blocker for next rel.
          Patrick Hunt made changes -
          Field Original Value New Value
          Fix Version/s 3.3.2 [ 12315108 ]
          Fix Version/s 3.4.0 [ 12314469 ]
          Priority Major [ 3 ] Blocker [ 1 ]
          Jeff Hodges made changes -
          Link This issue is duplicated by ZOOKEEPER-813 [ ZOOKEEPER-813 ]
          Hide
          Brian Fox added a comment -

          Since the poms were correct and the deployed location simply wrong, I copied the artifacts to the correct path which is org/apache/zookeeper. Give it a few hours to sync to central.

          Show
          Brian Fox added a comment - Since the poms were correct and the deployed location simply wrong, I copied the artifacts to the correct path which is org/apache/zookeeper. Give it a few hours to sync to central.
          Hide
          Olaf Krische added a comment -

          Hello,

          thank you for the copy, but its still not in the right location.

          With groupid = "org.apache.zookeeper" and artificatid = "zookeeper", the right location is:

          http://repo1.maven.org/maven2/org/apache/zookeeper/zookeeper/3.3.1/zookeeper-3.3.1.pom

          So it would be great to give it another try!

          Show
          Olaf Krische added a comment - Hello, thank you for the copy, but its still not in the right location. With groupid = "org.apache.zookeeper" and artificatid = "zookeeper", the right location is: http://repo1.maven.org/maven2/org/apache/zookeeper/zookeeper/3.3.1/zookeeper-3.3.1.pom So it would be great to give it another try!
          Hide
          Alexander Warschun added a comment -

          would also like to see this fixed, maybe with another move to path /org/apache. thx a lot

          Show
          Alexander Warschun added a comment - would also like to see this fixed, maybe with another move to path /org/apache. thx a lot
          Hide
          Brian Fox added a comment -

          brain cramp, it's in the proper location now.

          Show
          Brian Fox added a comment - brain cramp, it's in the proper location now.
          Hide
          Olaf Krische added a comment -

          checked with 3.3.1 and works for me.

          thank you!

          Show
          Olaf Krische added a comment - checked with 3.3.1 and works for me. thank you!
          Hide
          Patrick Hunt added a comment -

          A user verified (see comment) that this is now fixed. Closing.

          Show
          Patrick Hunt added a comment - A user verified (see comment) that this is now fixed. Closing.
          Patrick Hunt made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Hadoop Flags [Reviewed]
          Resolution Fixed [ 1 ]
          Mahadev konar made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          96d 22h 52m 1 Patrick Hunt 15/Sep/10 16:39
          Resolved Resolved Closed Closed
          434d 3h 42m 1 Mahadev konar 23/Nov/11 19:22

            People

            • Assignee:
              Unassigned
              Reporter:
              Chris Conrad
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development