Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.5.0
    • Component/s: quorum, server
    • Labels:
      None

      Description

      http://hudson.zones.apache.org/hudson/job/ZooKeeper-trunk/675/testReport/org.apache.zookeeper.test/LETest/testLE/

      junit.framework.AssertionFailedError: Threads didn't join
      at org.apache.zookeeper.test.LETest.testLE(LETest.java:116)

        Issue Links

          Activity

          Rakesh R made changes -
          Assignee Rakesh R [ rakeshr ] Patrick Hunt [ phunt ]
          Rakesh R added a comment -

          Oh Sorry!, due to my IE problem, mistakenly the issue got assigned to me.
          So reassigning back to previous state.

          Rakesh R made changes -
          Assignee Rakesh R [ rakeshr ]
          Patrick Hunt made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Patrick Hunt added a comment -

          I haven't seen this in a while. I recently committed ZOOKEEPER-1160 which might also be related. Closing for now.

          Thomas Koch added a comment -

          Maybe this issue can be closed? It looked like a duplicate of a bug that has been solved. I also couldn't find the logs of jenkins build 675 anymore.

          Mahadev konar made changes -
          Fix Version/s 3.5.0 [ 12316644 ]
          Fix Version/s 3.4.0 [ 12314469 ]
          Patrick Hunt made changes -
          Fix Version/s 3.4.0 [ 12314469 ]
          Fix Version/s 3.3.0 [ 12313976 ]
          Patrick Hunt added a comment -

          Pushing to 3.4.0 per Flavio's comment.

          Patrick Hunt added a comment -

          Henry/Flavio think this is related to ZOOKEEPER-569, let's get that one in and then see if it crops up again.

          Patrick Hunt made changes -
          Field Original Value New Value
          Link This issue is blocked by ZOOKEEPER-569 [ ZOOKEEPER-569 ]
          Flavio Junqueira added a comment -

          I agree with Henry, that's what it looks like; at least I couldn't find any evidence on the logs of anything unusual.

          Patrick Hunt created issue -

            People

            • Assignee:
              Patrick Hunt
              Reporter:
              Patrick Hunt
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development