ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-557

Upload Zookeeper jars to a public maven repository

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 3.3.0
    • Component/s: None
    • Labels:
      None

      Description

      There are many cool release of hadoop zookeeper and this project is an apache project, as the maven project.
      But the released jars must be download manually and then deploy to a private repository before they can be used by developer using maven2.

      Please could you upload the zookeeper jars on the public maven2 repository ?

      Of course, we can help to deploy those artifact if necessary.

        Activity

        Cyril Lakech created issue -
        Cyril Lakech added a comment -

        Here is a sample pom.xml

        <?xml version="1.0" encoding="UTF-8"?>
        <project>
        <modelVersion>4.0.0</modelVersion>
        <groupId>org.apache.hadoop</groupId>
        <artifactId>zookeeper</artifactId>
        <version>3.2.1</version>
        </project>

        When you release zookeeper you could upload the jar and this pom to the public maven repository. For instance, the hadoop avro project seems to be uploaded on the public repo. You could contact the hadoop avro team to know how do they upload their last release (avro 1.2.0)

        Cyril Lakech added a comment -

        How to upload a jar to the Apache directory ?

        The public answer :
        http://maven.apache.org/guides/mini/guide-central-repository-upload.html

        The apache internal answer :
        http://www.apache.org/dev/repository-faq.html

        Patrick Hunt added a comment -

        duplicate of ZOOKEEPER-224

        looks like all the building blocks are in place now for this to happen in the 3.3.0 release. Thanks!

        Patrick Hunt made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 3.3.0 [ 12313976 ]
        Resolution Duplicate [ 3 ]
        Patrick Hunt made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        13d 21m 1 Patrick Hunt 06/Nov/09 21:24
        Resolved Resolved Closed Closed
        139d 20h 1 Patrick Hunt 26/Mar/10 17:25

          People

          • Assignee:
            Unassigned
            Reporter:
            Cyril Lakech
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development