Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.2.1
    • Fix Version/s: 3.3.0
    • Component/s: server
    • Labels:
      None

      Description

      the following test failed:

      http://hudson.zones.apache.org/hudson/view/ZooKeeper/job/ZooKeeper-trunk/462/testReport/org.apache.zookeeper.test/QuorumQuotaTest/testQuotaWithQuorum/

      here's the interesting log:

      2009-09-16 10:35:52,728 - WARN [CommitProcessor:1:DataTree@409] - Quota exceeded: /a bytes=1808 limit=1000
      2009-09-16 10:36:34,000 - INFO [SessionTracker:SessionTrackerImpl@133] - Expiring session 0x423c26c1d220000
      2009-09-16 10:36:12,725 - WARN [main-SendThread(localhost:11225):ClientCnxn$SendThread@969] - Exception closing session 0x423c26c1d220000 to sun.nio.ch.SelectionKeyImpl@a7dd39
      java.io.IOException: TIMED OUT
      at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:908)

      looks like a create call hung and the session eventually expired

      perhaps updating the quota had some issue? deadlock or ...

        Activity

        Mahadev konar added a comment -

        We havent seen this again for a long time. I am closing this bug and will open another one in case we see the problem again!

        Patrick Hunt added a comment -

        the following trunk failure looks similar:

        http://hudson.zones.apache.org/hudson/view/ZooKeeper/job/ZooKeeper-trunk/460/testReport/org.apache.zookeeper.test/AsyncTest/testHammer/

        take a look starting at this timestamp: 2009-09-14 10:33:27,788


          People

          • Assignee:
            Mahadev konar
            Reporter:
            Patrick Hunt
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development