ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-494

zookeeper should install include headers in /usr/local/include/zookeeper

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Duplicate
    • Affects Version/s: 3.2.0
    • Fix Version/s: 3.4.0
    • Component/s: c client
    • Labels:
      None
    • Release Note:
      Changed install path of c-client header files to /usr/local/include/zookeeper

      Description

      Hello,

      Currently all the c client header files get installed under /usr/local/include/c-client-src . Ideally they should get installed in /usr/local/include/zookeeper .

      1. install.patch
        0.4 kB
        Isabel Drost-Fromm

        Issue Links

          Activity

          Isabel Drost-Fromm added a comment -

          Changed the install path for header libs to /usr/local/include/zookeeper

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12417964/install.patch
          against trunk revision 808557.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no tests are needed for this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Zookeeper-Patch-vesta.apache.org/192/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Zookeeper-Patch-vesta.apache.org/192/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: http://hudson.zones.apache.org/hudson/job/Zookeeper-Patch-vesta.apache.org/192/console

          This message is automatically generated.

          Mahadev konar added a comment -

          the patch looks good but I have a concern. THe patch changes where the include files are stored meaning its NOT backwards compatible. Users will have to change either there code or makefiles to adapt to this new change, right?

          Isabel Drost-Fromm added a comment -

          Yes, users will need to change the include path for zookeeper header-files in their Makefiles.

          Mahadev konar added a comment -

          right, so then we should wait for 4.0 for this patch ? we cannot commit this to 3.3 since it will break backwards compatbility (though what you suggest is the right thing to do)....

          Isabel Drost-Fromm added a comment -

          Sure. Makes perfect sense. (Btw.: Originally the proposal did not come from me but from Michi Mutsuzaki )

          Mahadev konar added a comment -

          moving it to 4.0...

          Mahadev konar added a comment -

          Resolving as a duplicate of ZOOKEEPER-1033.

          thanks Isabel.


            People

            • Assignee:
              Isabel Drost-Fromm
              Reporter:
              Michi Mutsuzaki
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development