Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-4290

Update commons-io to fix vulnerability

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Currently, zookeeper uses commons-io 2.6 which contains [CVE 2021-29425](https://nvd.nist.gov/vuln/detail/CVE-2021-29425).  This has been fixed in version 2.7 and above.  Update zookeeper to use the latest commons-io library.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              boojapho Boojapho
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: