Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-3460

Zookeeper 3.4.13: keeps crashing after a repave in cloudnative environment.

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.4.13
    • Fix Version/s: None
    • Component/s: other
    • Labels:
      None
    • Environment:

      Kubernetes Cloud Native Environment.

      Description

      We have used the minimal binary installation for Zookeeper and every time after repave the zookeeper keeps crashing with following logs...

      I have attached the zookeeper crash logs and deployment information. Is this related to one of the NULL Pointer Issues mentioned in https://issues.apache.org/jira/browse/ZOOKEEPER-3009 ?

      We are trying to find the exact issue here so our cloud native platform guys can help us further. Kindly let us know how to turn on debugging further.

        Attachments

        1. ZooKeeperDeploymentDescription.txt
          4 kB
          Chandrasekhar
        2. ZookeeperCrashLog.txt
          6 kB
          Chandrasekhar

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              chandranc.rao@oracle.com Chandrasekhar
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: