Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-1602

a change to QuorumPeerConfig's API broke compatibility with HBase

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.5.0
    • Fix Version/s: 3.5.0
    • Component/s: server
    • Labels:
    • Hadoop Flags:
      Reviewed

      Description

      The following patch broke an API that's in use by HBase. Otherwise current trunk compiles fine when used by hbase:

      ZOOKEEPER-1411. Consolidate membership management, distinguish between static and dynamic configuration parameters (Alex Shraer via breed)

      Considering it a blocker even though it's not really a "public" API. If possible we should add back "getServers" method on QuorumPeerConfig to reduce friction for the hbase team.

        Attachments

        1. ZOOKEEPER-1602.patch
          1.0 kB
          Alexander Shraer

          Activity

            People

            • Assignee:
              shralex Alexander Shraer
              Reporter:
              phunt Patrick Hunt
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: