Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Closing of session is not deleting all the ephemeral nodes.

      (Eg: From the log, session Id:0x23b6ad21d160000 creates two ephemerals(/CONFIGNODE/NP2147483647 and /ACTIVE/192.168.11.94) but when the session expires, only /CONFIGNODE/NP2147483647 is getting deleted)

      1. ZKServerLogs.tar.gz
        2.13 MB
        Deepa Muthunoori

        Activity

        Patrick Hunt added a comment -

        Hi Deepa, I looked at the transaction logs, afaict this is not a bug, rather the znode you mention is not deleted on session expiration because it was already explicitly deleted by another session.

        I dumped the txnlog from zookeeper2, here is the section of interest. Notice that 0x23b6ad600580000 explicitly deletes /ACTIVE/192.168.11.94 prior to session 0x23b6ad21d160000 being closed:

        12/5/12 3:33:37 AM PST session 0x23b6ad600580000 cxid 0x50bffce0 zxid 0x80000000f delete '/ACTIVE/192.168.11.94
        12/5/12 3:33:37 AM PST session 0x23b6ad600580000 cxid 0x50bffce1 zxid 0x800000010 create '/STANDBY/192.168.11.94,#00004e6f6465,v{s{31,s{'world,'anyone}}},T,16
        12/5/12 3:33:37 AM PST session 0x23b6ad600580000 cxid 0x50bffce2 zxid 0x800000011 setData '/STANDBY/192.168.11.94,#000000000000d00000003139322e3136382e31312e393411,1
        12/5/12 3:33:37 AM PST session 0x23b6ad600580000 cxid 0x50bffce3 zxid 0x800000012 delete '/LOCKNODE
        12/5/12 3:33:58 AM PST session 0x33b6ad37c350000 cxid 0x0 zxid 0x800000013 closeSession null
        12/5/12 3:33:58 AM PST session 0x23b6ad21d160000 cxid 0x0 zxid 0x800000014 closeSession null
        

        I can see a bit later (same second, notice the zxid) 0x23b6ad600580000 goes ahead and recreates the znode:

        12/5/12 3:33:58 AM PST session 0x23b6ad600580000 cxid 0x50bffcf0 zxid 0x800000025 create '/ACTIVE/192.168.11.94,#00004e6f6465,v{s{31,s{'world,'anyone}}},T,18
        

        Is there something I'm missing here? afaict things are working properly, at least on the ZK side of things.

        Patrick Hunt added a comment -

        Not sure if it's related but there was a recent report of ephemeral troubles here: https://issues.cloudera.org/browse/DISTRO-448
        (this is 3.4.3 with some SASL fixes, also includes ZOOKEEPER-1489)


          People

          • Assignee:
            Patrick Hunt
            Reporter:
            Deepa Muthunoori
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development