ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-1460

IPv6 literal address not supported for quorum members

    Details

    • Type: Bug Bug
    • Status: Reopened
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 3.4.3
    • Fix Version/s: 3.4.9, 3.5.2, 3.6.0
    • Component/s: quorum
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Via code inspection, I see that the "server.nnn" configuration key does not support literal IPv6 addresses because the property value is split on ":". In v3.4.3, the problem is in QuorumPeerConfig:

      String parts[] = value.split(":");
      InetSocketAddress addr = new InetSocketAddress(parts[0],
                              Integer.parseInt(parts[1]));
      

      In the current trunk (http://svn.apache.org/viewvc/zookeeper/trunk/src/java/main/org/apache/zookeeper/server/quorum/QuorumPeer.java?view=markup) this code has been refactored into QuorumPeer.QuorumServer, but the bug remains:

      String serverClientParts[] = addressStr.split(";");
      String serverParts[] = serverClientParts[0].split(":");
      addr = new InetSocketAddress(serverParts[0],
                              Integer.parseInt(serverParts[1]));
      

      This bug probably affects very few users because most will naturally use a hostname rather than a literal IP address. But given that IPv6 addresses are supported for clients via ZOOKEEPER-667 it seems that server support should be fixed too.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        1233d 23h 49m 1 Chris Nauroth 16/Sep/15 19:39
        Patch Available Patch Available Resolved Resolved
        31d 21h 23m 1 Chris Nauroth 18/Oct/15 17:02
        Resolved Resolved Reopened Reopened
        16d 12h 10m 1 Rakesh R 04/Nov/15 05:12
        Raul Gutierrez Segales added a comment -

        Chris Nauroth: lets target this in 3.4.9 - thanks!

        Raul Gutierrez Segales made changes -
        Fix Version/s 3.4.9 [ 12334700 ]
        Fix Version/s 3.4.8 [ 12326517 ]
        Chris Nauroth added a comment -

        I just realized that we don't actually have a patch applicable to branch-3.4 ready to go, so I can't proceed with the commit immediately. If someone wants to rebase to branch-3.4, then I'll review and commit it. Otherwise, I'll put this into my queue and rebase later when I get some free time.

        Chris Nauroth made changes -
        Fix Version/s 3.4.8 [ 12326517 ]
        Raul Gutierrez Segales added a comment -

        Chris Nauroth: please go ahead - thanks!

        Chris Nauroth added a comment -

        Raul Gutierrez Segales and Rakesh R, since we've shipped 3.4.7, do you mind if I commit this to branch-3.4 now?

        Benedict Jin added a comment -

        I see, ZOOKEEPER-107 changed that for adding/removing hosts to/from the server cluster dynamically. Thank you, my fault.

        Chris Nauroth added a comment -

        Hello Benedict Jin. That code was not commented out as part of this patch. Instead, git blame traces that to ZOOKEEPER-107 (dynamic reconfiguration).

        Benedict Jin added a comment -

        Why did Chris Nauroth comment out those following code in line 821?
        ```java
        // if (!getView().containsKey(myid))

        { // throw new RuntimeException("My id " + myid + " not in the peer list"); //}

        ```
        https://github.com/apache/zookeeper/blob/trunk/src/java/main/org/apache/zookeeper/server/quorum/QuorumPeer.java

        Rakesh R made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Rakesh R added a comment -

        OK, it need not be in 3.4.7 release until someone wants this urgently. I'm just reopening this issue to back port the changes to branch-3.4, otw we may forget about this task (tracking purpose).

        Chris Nauroth added a comment -

        Hi Rakesh R. Were you interested in getting this into the soon-to-come 3.4.7 release? I believe Raul Gutierrez Segales plans to get rolling on that soon. I'm not sure I'll have time myself to rebase this patch for branch-3.4 soon enough. If someone else would like to do so, then I'd be happy to squeeze in a code review though.

        Rakesh R added a comment -

        Thanks all for taking care this. I think we could consider this fix to branch-3.4 as well.
        cc: Chris Nauroth, Joseph Walton

        Please see branch-3.4 logic:
        QuorumPeerConfig.java#L182, QuorumPeerConfig.java#L215

        value.split(":");
        
        Hudson added a comment -

        FAILURE: Integrated in ZooKeeper-trunk #2803 (See https://builds.apache.org/job/ZooKeeper-trunk/2803/)
        ZOOKEEPER-1460: IPv6 literal address not supported for quorum members (Joseph Walton via cnauroth) (cnauroth: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1709293)

        • trunk/CHANGES.txt
        • trunk/src/java/main/org/apache/zookeeper/server/quorum/QuorumPeer.java
        • trunk/src/java/test/org/apache/zookeeper/server/quorum/QuorumServerTest.java
        Chris Nauroth made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Chris Nauroth added a comment -

        I have committed this to trunk and branch-3.5.

        Joseph Walton, thank you for contributing the patch.

        Thank you also to everyone who helped with code review and testing: Boying Lu, Raul Gutierrez Segales and Hongchao Deng.

        Chris Nauroth made changes -
        Hadoop Flags Reviewed [ 10343 ]
        Chris Nauroth added a comment -

        I am +1 for patch v003. I plan to commit this to trunk and branch-3.5. I'll wait until Friday, 10/16, before committing, just in case any other committers want to give it one last look.

        Boying Lu added a comment -

        Since the ZOOKEEPER-1506 has been checked in, can we check in the patch now?

        Flavio Junqueira added a comment -

        I don't think we have agreed on removing the alpha label for the next release, but it sounds reasonable if the community feels it is stable enough for regular production use.

        Chris Nauroth made changes -
        Fix Version/s 3.5.2 [ 12331981 ]
        Fix Version/s 3.6.0 [ 12326518 ]
        Chris Nauroth added a comment -

        I want to get this fixed in ZK 3.5.0, so can we add the '3.5.0' to the 'Fix Version' list of ZOOKEEPER-1506?

        Just to clarify, the next release in the 3.5 line will be 3.5.2. I don't recall if the plan is for that one to still be labeled alpha or beta, but the number is going to be 3.5.2.

        I've updated fix version on this issue to show 3.5.2 and 3.6.0 (trunk).

        Boying Lu added a comment -

        OK, got it. I want ot get this fixed in ZK 3.5.0, so can we add the '3.5.0' to the 'Fix Version' list of ZOOKEEPER-1506?

        Chris Nauroth added a comment -

        Is there anything else I can do to get it fixed in ZK 3.5.0 ?

        Boying Lu, you've been very helpful already, and thank you!

        At this point, the plan is to wait for ZOOKEEPER-1506 to finish and get committed first. Depending on the final outcome of the ZOOKEEPER-1506 patch, we might need to rebase this once again and do another pre-commit test run.

        After that, if you want to help more, then I suggest watching the dev@zookeeper.apache.org list for an announcement of the next 3.5.x release candidate. When that's published, you could download it, repeat your testing with the release candidate, and then reply to dev@zookeeper.apache.org with a +1 (or -1 if you found something wrong). That would give us confidence that the fix made it into the release candidate correctly.

        Boying Lu added a comment -

        Is there anything else I can do to get it fixed in ZK 3.5.0 ?

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12756423/ZOOKEEPER-1460-for-3.5.0.patch
        against trunk revision 1702378.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2881//console

        This message is automatically generated.

        Boying Lu made changes -
        Attachment ZOOKEEPER-1460-for-3.5.0.patch [ 12756423 ]
        Boying Lu added a comment -

        The patch 1460.003 can't be applied to the 3.5.0-alpha codebase directly.
        So I made a patch for 3.5.0-alpha with some minor changes.

        I've tested the patch in my IPv6 environment and it works well.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12756346/ZOOKEEPER-1460.003.patch
        against trunk revision 1702378.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2880//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2880//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2880//console

        This message is automatically generated.

        Chris Nauroth made changes -
        Attachment ZOOKEEPER-1460.003.patch [ 12756346 ]
        Chris Nauroth added a comment -

        I'm attaching the same patch, reformatted with git diff --no-prefix to satisfy pre-commit.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12756254/ZOOKEEPER-1460-accept-square-bracket-delimited-IPv6-literals.2.diff
        against trunk revision 1702378.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2879//console

        This message is automatically generated.

        Chris Nauroth made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Chris Nauroth added a comment -

        Thank you, Joseph Walton! I'm submitting this for our pre-commit test run. FYI, in the future, you can do this by clicking the Submit Patch button.

        Joseph Walton made changes -
        Joseph Walton added a comment -

        I've attached the previous patch rebased against r1702378.

        Boying Lu added a comment -

        Please let me know when the patch is ready for test. I can test it on ZK 3.5.0

        Chris Nauroth added a comment -

        Can we get it fixed in 3.5.0 release?

        Yes, I think so. We just need the patch rebased against the current version of the codebase.

        I just realized the original patch was contributed by Joseph Walton, so I've updated the assignee. Joseph Walton, are you able to create another version of this patch that applies to the current trunk branch?

        I can help to test the patch.

        Boying Lu, thank you for the offer to help test!

        Chris Nauroth made changes -
        Assignee Thawan Kooburat [ thawan ] Joseph Walton [ joe@kafsemo.org ]
        Boying Lu added a comment -

        I can help to test the patch.

        Boying Lu added a comment -

        Thanks a lot !
        Can we get it fixed in 3.5.0 release?

        Raul Gutierrez Segales added a comment -

        You are right Chris Nauroth, thanks!

        Chris Nauroth added a comment -

        The logic looks good, but the rebase will be significant, because ZOOKEEPER-2171 removed the HostNameUtils class.

        I suggest that we wait for ZOOKEEPER-1506 to get finalized and committed before we rebase and commit this. I think that will minimize churn on resolving merge conflicts. That will also give us a chance to make sure this patch remains consistent with the final version of the ZOOKEEPER-1506 patch.

        I'd be happy to help with a review on the final rebased patch. Thawan, thank you for contributing!

        Hongchao Deng added a comment -

        +1
        Thanks Raul for raising it up. I did remember there is some IPV6 issues.

        Raul Gutierrez Segales added a comment -

        lgtm, though I did wish we had Guava so we didnt' have to write our own validators

        Chris Nauroth, Hongchao Deng: can I get an extra +1 and then I'll merge (once it's rebased). Thanks!

        Raul Gutierrez Segales added a comment -

        Boying Lu: sure, mind rebasing the patch on top of master?

        Boying Lu added a comment -

        Can we fix it in ZK 3.5.0?

        Joseph Walton made changes -
        Joseph Walton added a comment -

        I've attached a patch to accept that syntax. Before splitting by : it attempts to extract a square-bracket-delimited component at the start of the string, and then splits the remainder as before.

        Tests for parsing are included.

        Dr. Martin Menzel added a comment -

        We should use a typical IPv6 address/port configuration like

        server.1=[1234::f4b5:3fff:fe0f:e96e]:2888:3888

        in the case of literal IPv6 addresses. I think this would be more handy than splitting the configuration in several different properties (host/port) like in the client case.

        From my point of view this issue is not a IPv6 show stopper, because especially in the IPv6 case there are hostnames defined in DNS of /etc/hosts. If we use the hostnames the configuration is no problem.

        Thawan Kooburat made changes -
        Field Original Value New Value
        Assignee Thawan Kooburat [ thawan ]
        Liping added a comment -

        Hi

        Is anyone looking into this issue?
        In our env, we do not want to depend on dns. So it is better if we have an official fix for it. Thanks.

        Liping

        Chris Dolan created issue -

          People

          • Assignee:
            Joseph Walton
            Reporter:
            Chris Dolan
          • Votes:
            4 Vote for this issue
            Watchers:
            17 Start watching this issue

            Dates

            • Created:
              Updated:

              Development