Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-1356

Avoid permanent caching of server IPs in the client

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 3.3.4, 3.4.2
    • Fix Version/s: None
    • Component/s: java client
    • Labels:
      None

      Description

      Relevant conversation on the dev mailing list - https://email.corp.linkedin.com/owa/redir.aspx?C=87f3d1e78c96438c8115e450f410d010&URL=http%3a%2f%2fmarkmail.org%2fmessage%2f3vzynx6rgurubf3p%3fq%3dPerforming%2bno%2bdowntime%2bhardware%2bchanges%2bto%2ba%2blive%2bzookeeper%2bcluster%2blist%3aorg%252Eapache%252Ehadoop%252Ezookeeper-dev

      Basically, the client caches the list of server IPs internally and maintains that list for the entire lifetime of the client. This limits the ability to remove/change a server node from a zookeeper cluster, without having to restart every client. Also, two levels of IP caching, one in the JVM and one in the zookeeper client code seems unnecessar.

      It would be ideal to provide a config option that would turn off this IP caching in the client and re-resolve the host names during the reconnect.

        Activity

        phunt Patrick Hunt added a comment -

        Duplicate of ZOOKEEPER-338

        bric3 Brice Dutheil added a comment -

        Neha Narkhede Could this ticket ZOOKEEPER-1506 be helpful ?

        fpj Flavio Junqueira added a comment -

        Brice Dutheil It does look like ZOOKEEPER-1506 resolved it.

        bric3 Brice Dutheil added a comment -

        It seems so.

        I'm looking forward the release of 3.4.8 by the way ;P
        Which would greatly simply the deployment on docker container.


          People

          • Assignee:
            nehanarkhede Neha Narkhede
            Reporter:
            nehanarkhede Neha Narkhede
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development