Uploaded image for project: 'Zeppelin'
  1. Zeppelin
  2. ZEPPELIN-3263

Do not use Firefox >=55 for integration testing

    XMLWordPrintableJSON

    Details

    • Type: Test
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 0.7.3
    • Fix Version/s: None
    • Component/s: CI-infra
    • Labels:
      None

      Description

      I'm currently debugging locally why do integration tests fail for https://github.com/apache/zeppelin/pull/2679

       

      One of the problems in my setup was that I use Firefox 59, and Selenium simply hangs with it. At the same time, Chrome and Safari work fine. According to https://seleniumhq.wordpress.com/2017/08/09/firefox-55-and-selenium-ide , Firefox versions 55+ do not work with Selenium, so I would propose to skip them when creating the WebDriver.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mephi42 mephi42
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 10m
                10m