Uploaded image for project: 'Zeppelin'
  1. Zeppelin
  2. ZEPPELIN-1712

Problem connecting to websocket

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.6.0, 0.6.1
    • Fix Version/s: None
    • Component/s: front-end, zeppelin-server
    • Labels:

      Description

      Hello,
      A little bit background of the issue:
      I have a requirement at my company to connect to zeppelin web-server in the notebook level and perform some basic operations such as- save, run and edit paragraphs. I also have to create a few custom visualizations, with these paragraphs. The base project is in Google Polymer and I have been using https://github.com/hph/web-socket/ as my websocket component. My front end runs in port '3000' and communicates with zeppelin websocket server located at => ws://localhost:8080/ws/.

      Now to the problem, The 'GET_NOTE' operation works fine; The 'COMMIT_PARAGRAPH' operation works fine. But 'RUN_PARAGRAPH' never works, it just returns => status:"ERROR". I'll attach my payload with this bug. I tried with versions 0.6.0 and 0.6.1.

      This is my websocket:
      <web-socket id="socket" url="[[ ws ]]" json on-open="_onOpen" on-close="_onClose" on-message="handleResponse" on-error="_onError"></web-socket>

        Attachments

        1. payloads-nov-29.json
          1 kB
          Sravan S
        2. zeppelin-fly-FLY-DT223.log
          63 kB
          Sravan S
        3. log.txt
          8 kB
          Sravan S
        4. demo-payload.json
          24 kB
          Sravan S

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ess_ess Sravan S
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: