Uploaded image for project: 'Apache YuniKorn'
  1. Apache YuniKorn
  2. YUNIKORN-1820

update protobuf & grpc dependencies

    XMLWordPrintableJSON

Details

    Description

      We are using really old versions of both in the scheduler interface.

      The build makefile needs to be updated to move to a recent version of the protoc compiler and plugin to start with.
      Current version for protoc == 23.2, current version for protoc-gen-go == v1.3.0
      Move from go install to a curl based install for the go plugin to align with the protoc install
      grpc is also lagging way behind curently at 1.55, our reference is 1.26

      Attachments

        Issue Links

          Activity

            People

              yangpoan PoAn Yang
              wilfreds Wilfred Spiegelenburg
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: