Uploaded image for project: 'Yetus'
  1. Yetus
  2. YETUS-426

Parser error on specifying just -V

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.4.0
    • Component/s: Release Doc Maker
    • Labels:
      None

      Description

      releasedocmaker has an option (-V ) to display the release version and exit(as per the docs). However, currently it is not possible to give just -V option because of the way the validations are being done. For example

      (releasedocmaker)ajay@ultron:~/projects/yetus (425)$ python release-doc-maker/releasedocmaker.py -V
      Usage: releasedocmaker.py [OPTIONS] --project PROJECT [--project PROJECT] --version VERSION [--version VERSION2 ...]
      
      releasedocmaker.py: error: At least one version needs to be supplied
      
      

        Attachments

        1. YETUS-426.00.patch
          2 kB
          Ajay Yadav

          Activity

            People

            • Assignee:
              ajayyadava Ajay Yadav
              Reporter:
              ajayyadava Ajay Yadav
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: