Uploaded image for project: 'Yetus'
  1. Yetus
  2. YETUS-405

Minor typo for python-dateutil package

    XMLWordPrintableJSON

    Details

      Description

      r-d-m doc says:

      dateutil may be installed via pip:  `pip install python.dateutil`
      

      but with a older version of pip, the above command fails:

      (v)sekikn@ubuntu-trusty:~/yetus$ pip -V
      pip 1.5.4 from /home/sekikn/.virtualenvs/v/local/lib/python2.7/site-packages (python 2.7)
      (v)sekikn@ubuntu-trusty:~/yetus$ pip install python.dateutil                                                                       
      Downloading/unpacking python.dateutil
        Could not find any downloads that satisfy the requirement python.dateutil
      Cleaning up...
      No distributions at all found for python.dateutil
      Storing debug log for failure in /home/sekikn/.pip/pip.log
      (v)sekikn@ubuntu-trusty:~/yetus$ pip list                                                                                          
      argparse (1.2.1)
      pip (1.5.4)
      setuptools (2.2)
      wsgiref (0.1.2)
      

      It succeeds with a more recent version, but displays a warning:

      (v)sekikn@ubuntu-trusty:~/yetus$ pip install --upgrade pip
      
      (snip)
      
      Successfully installed pip
      Cleaning up...
      (v)sekikn@vagrant-ubuntu-trusty:~/yetus$ pip -V
      pip 8.1.2 from /home/sekikn/.virtualenvs/v/local/lib/python2.7/site-packages (python 2.7)
      (v)sekikn@ubuntu-trusty:~/yetus$ pip install python.dateutil                                                                       
      
      (snip)
      
      Installing collected packages: six, python.dateutil
      Exception:
      Traceback (most recent call last):
        File "/home/sekikn/.virtualenvs/v/local/lib/python2.7/site-packages/pip/basecommand.py", line 215, in main
          status = self.run(options, args)
        File "/home/sekikn/.virtualenvs/v/local/lib/python2.7/site-packages/pip/commands/install.py", line 317, in run
          prefix=options.prefix_path,
        File "/home/sekikn/.virtualenvs/v/local/lib/python2.7/site-packages/pip/req/req_set.py", line 742, in install
          **kwargs
        File "/home/sekikn/.virtualenvs/v/local/lib/python2.7/site-packages/pip/req/req_install.py", line 831, in install
          self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
        File "/home/sekikn/.virtualenvs/v/local/lib/python2.7/site-packages/pip/req/req_install.py", line 1032, in move_wheel_files
          isolated=self.isolated,
        File "/home/sekikn/.virtualenvs/v/local/lib/python2.7/site-packages/pip/wheel.py", line 348, in move_wheel_files
          assert info_dir, "%s .dist-info directory not found" % req
      AssertionError: python.dateutil .dist-info directory not found
      
      (snip)
      
      (v)sekikn@ubuntu-trusty:~/yetus$ pip list
      pip (8.1.2)
      python-dateutil (2.5.3)
      setuptools (2.2)
      six (1.10.0)
      

      ... and it doesn't work for uninstall.

      (v)sekikn@ubuntu-trusty:~/yetus$ pip uninstall python.dateutil                                                                     
      Cannot uninstall requirement python.dateutil, not installed
      

        Attachments

        1. YETUS-405.01.patch
          1 kB
          Karen Clark

          Issue Links

            Activity

              People

              • Assignee:
                clarkkaren Karen Clark
                Reporter:
                sekikn Kengo Seki
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: