Uploaded image for project: 'Yetus'
  1. Yetus
  2. YETUS-337

Upgrade version of pylint used in Dockerfile

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.2.0
    • Fix Version/s: 0.3.0
    • Component/s: Precommit
    • Labels:
      None
    • Release Note:
      The default precommit Dockerfile now relies on pip to grab an up-to-date version of pylint, rather than rely on the version shipped in dpkg.

      Description

      The default pylint version in the trusty Dockerfile is 1.1.0. This is three years old and the warnings are pretty different from more recent version of pylint, let's update.

        Attachments

        1. YETUS-337.test.patch
          9 kB
          Sean Busbey
        2. YETUS-337.001.patch
          1.0 kB
          Andrew Wang

          Activity

            People

            • Assignee:
              andrew.wang Andrew Wang
              Reporter:
              andrew.wang Andrew Wang
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: