Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-9568

NPE in MiniYarnCluster during FileSystemNodeAttributeStore.recover

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.3.0
    • Fix Version/s: 3.3.0
    • Component/s: resourcemanager, test
    • Labels:
      None
    • Environment:

      macos

      Description

      This seems new in trunk. As in "wasn't happening a couple of weeks ago". Its surfacing in the S3A committer tests which are trying to create MiniYarnClusters: all such tests are failing as the mini yarn cluster won't come up with an NPE in FileSystemNodeAttributeStore.recover

      I'm not sure why node labels are needed on test clusters; the default implies they should be off anyway.

      At the same time, I can't seem to find one specific change in the git log to say "this is causing the problem".

        Attachments

        1. npe.log
          44 kB
          Steve Loughran
        2. YARN-9568.001.patch
          1 kB
          Bibin Chundatt
        3. YARN-9568.002.patch
          1 kB
          Bibin Chundatt

          Issue Links

            Activity

              People

              • Assignee:
                stevel@apache.org Steve Loughran
                Reporter:
                stevel@apache.org Steve Loughran
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: