Description
Since the new RuncContainerRuntime will be using a lot of the same code as DockerLinuxContainerRuntime, it would be good to move a bunch of the DockerLinuxContainerRuntime code up a level to an abstract class that both of the runtimes can extend.
The new structure will look like:
OCIContainerRuntime (abstract class) - DockerLinuxContainerRuntime - RuncContainerRuntime
This JIRA should only change the structure of the code, not the actual semantics