Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-8950

Compilation fails with dependency convergence error for hbase.profile=2.0

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.2.0, 3.3.0
    • Fix Version/s: 3.2.0, 3.1.2, 3.3.0
    • Component/s: None
    • Labels:
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Dependency check for hbase-client package fails when source code is compiled with -Dhbase.profile=2.0

      [INFO] --- maven-enforcer-plugin:3.0.0-M1:enforce (depcheck) @ hadoop-yarn-server-timelineservice-hbase-client ---
      [WARNING]
      Dependency convergence error for org.eclipse.jetty:jetty-http:9.3.24.v20180605 paths to dependency are:
      +-org.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-client:3.3.0-SNAPSHOT
        +-org.apache.hadoop:hadoop-common:3.3.0-SNAPSHOT
          +-org.eclipse.jetty:jetty-server:9.3.24.v20180605
            +-org.eclipse.jetty:jetty-http:9.3.24.v20180605
      and
      +-org.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-client:3.3.0-SNAPSHOT
        +-org.apache.hbase:hbase-server:2.0.0-beta-1
          +-org.apache.hbase:hbase-http:2.0.0-beta-1
            +-org.eclipse.jetty:jetty-http:9.3.19.v20170502
      
      [WARNING]
      Dependency convergence error for org.eclipse.jetty:jetty-security:9.3.24.v20180605 paths to dependency are:
      +-org.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-client:3.3.0-SNAPSHOT
        +-org.apache.hadoop:hadoop-common:3.3.0-SNAPSHOT
          +-org.eclipse.jetty:jetty-servlet:9.3.24.v20180605
            +-org.eclipse.jetty:jetty-security:9.3.24.v20180605
      and
      +-org.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-client:3.3.0-SNAPSHOT
        +-org.apache.hbase:hbase-server:2.0.0-beta-1
          +-org.apache.hbase:hbase-http:2.0.0-beta-1
            +-org.eclipse.jetty:jetty-security:9.3.19.v20170502
      
      [WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence failed with message:
      Failed while enforcing releasability. See above detailed error message.
      

        Attachments

        1. YARN-8950.01.patch
          2 kB
          Rohith Sharma K S
        2. YARN-8950.01.patch
          2 kB
          Rohith Sharma K S
        3. YARN-8950.01.patch
          2 kB
          Sunil Govindan
        4. with-patch-compile-pass.out
          542 kB
          Rohith Sharma K S
        5. without-patch-compile-fail.out
          251 kB
          Rohith Sharma K S

          Issue Links

            Activity

              People

              • Assignee:
                rohithsharma Rohith Sharma K S
                Reporter:
                rohithsharma Rohith Sharma K S
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: