Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-6420

RM startup failure due to wrong order in nodelabel editlog

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-alpha4, 2.8.2
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Edit log file for nodelabel written in wrong order if StoreNewClusterNodeLabels addition is delayed and UpdateNodeToLabelsMappingsEvent is added to dispatcher.

      Configure RM admin client thread count to 2
      Add node label to cluster X - Client 1
      Delay event addition to dispatcher
      Replace node label on node1 to X - Client 2
      Make sure UpdateNodeToLabelsMappingsEvent added to dispatcher first.
      Restart resource manager

      2017-03-31 16:20:42,236 | WARN  | main-EventThread | Exception handling the winning of election | ActiveStandbyElector.java:836
      org.apache.hadoop.ha.ServiceFailedException: RM could not transition to Active
              at org.apache.hadoop.yarn.server.resourcemanager.EmbeddedElectorService.becomeActive(EmbeddedElectorService.java:128)
              at org.apache.hadoop.ha.ActiveStandbyElector.becomeActive(ActiveStandbyElector.java:832)
              at org.apache.hadoop.ha.ActiveStandbyElector.processResult(ActiveStandbyElector.java:422)
              at org.apache.zookeeper.ClientCnxn$EventThread.processEvent(ClientCnxn.java:728)
              at org.apache.zookeeper.ClientCnxn$EventThread.run(ClientCnxn.java:600)
      Caused by: org.apache.hadoop.ha.ServiceFailedException: Error when transitioning to Active mode
              at org.apache.hadoop.yarn.server.resourcemanager.AdminService.transitionToActive(AdminService.java:331)
              at org.apache.hadoop.yarn.server.resourcemanager.EmbeddedElectorService.becomeActive(EmbeddedElectorService.java:126)
              ... 4 more
      Caused by: org.apache.hadoop.service.ServiceStateException: java.io.IOException: Not all labels being replaced contained by known label collections, please check, new labels=[1]
              at org.apache.hadoop.service.ServiceStateException.convert(ServiceStateException.java:59)
              at org.apache.hadoop.service.AbstractService.start(AbstractService.java:204)
              at org.apache.hadoop.service.CompositeService.serviceStart(CompositeService.java:120)
              at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager$RMActiveServices.serviceStart(ResourceManager.java:642)
              at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
              at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.startActiveServices(ResourceManager.java:1042)
              at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager$1.run(ResourceManager.java:1083)
              at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager$1.run(ResourceManager.java:1079)
              at java.security.AccessController.doPrivileged(Native Method)
              at javax.security.auth.Subject.doAs(Subject.java:422)
      
      
      1. YARN-6420.0003.patch
        2 kB
        Bibin A Chundatt
      2. YARN-6420.0002.patch
        3 kB
        Bibin A Chundatt
      3. YARN-6420.0001.patch
        8 kB
        Bibin A Chundatt

        Activity

        vinodkv Vinod Kumar Vavilapalli added a comment -

        2.8.1 became a security release. Moving fix-version to 2.8.2 after the fact.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11591 (See https://builds.apache.org/job/Hadoop-trunk-Commit/11591/)
        YARN-6420. RM startup failure due to wrong order in nodelabel editlog (varunsaxena: rev 19b89c4c7be0236aafded560b7bcad7e39d1c4ed)

        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/nodelabels/RMNodeLabelsManager.java
        bibinchundatt Bibin A Chundatt added a comment -

        Thank you Naganarasimha Garla for review and Varun Saxena for commit

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11527 (See https://builds.apache.org/job/Hadoop-trunk-Commit/11527/)
        YARN-6420. RM startup failure due to wrong order in nodelabel editlog (varunsaxena: rev 19b89c4c7be0236aafded560b7bcad7e39d1c4ed)

        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/nodelabels/RMNodeLabelsManager.java
        varun_saxena Varun Saxena added a comment -

        Committed to trunk, branch-2 and branch-2.8
        Thanks Bibin A Chundatt for your contribution and Naga for reviews.

        varun_saxena Varun Saxena added a comment -

        +1.
        Will commit it later today.

        Naganarasimha Naganarasimha G R added a comment -

        Fix LGTM, +1
        Thanks for working on the patch !

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 22s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 13m 39s trunk passed
        +1 compile 0m 31s trunk passed
        +1 checkstyle 0m 25s trunk passed
        +1 mvnsite 0m 34s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 findbugs 0m 58s trunk passed
        +1 javadoc 0m 21s trunk passed
        +1 mvninstall 0m 30s the patch passed
        +1 compile 0m 28s the patch passed
        +1 javac 0m 28s the patch passed
        +1 checkstyle 0m 21s the patch passed
        +1 mvnsite 0m 30s the patch passed
        +1 mvneclipse 0m 11s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 1s the patch passed
        +1 javadoc 0m 18s the patch passed
        -1 unit 38m 7s hadoop-yarn-server-resourcemanager in the patch failed.
        +1 asflicense 0m 18s The patch does not generate ASF License warnings.
        60m 12s



        Reason Tests
        Failed junit tests hadoop.yarn.server.resourcemanager.TestRMRestart



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:a9ad5d6
        JIRA Issue YARN-6420
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12861861/YARN-6420.0003.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 1ab377b3316f 3.13.0-107-generic #154-Ubuntu SMP Tue Dec 20 09:57:27 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 6eba792
        Default Java 1.8.0_121
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-YARN-Build/15502/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/15502/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/15502/console
        Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 19s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 12m 48s trunk passed
        +1 compile 0m 27s trunk passed
        +1 checkstyle 0m 19s trunk passed
        +1 mvnsite 0m 28s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 0m 55s trunk passed
        +1 javadoc 0m 28s trunk passed
        +1 mvninstall 0m 25s the patch passed
        +1 compile 0m 24s the patch passed
        +1 javac 0m 24s the patch passed
        +1 checkstyle 0m 16s the patch passed
        +1 mvnsite 0m 26s the patch passed
        +1 mvneclipse 0m 11s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 59s the patch passed
        +1 javadoc 0m 25s the patch passed
        +1 unit 2m 23s hadoop-yarn-common in the patch passed.
        +1 asflicense 0m 18s The patch does not generate ASF License warnings.
        23m 2s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:a9ad5d6
        JIRA Issue YARN-6420
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12861857/YARN-6420.0002.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux e4067b29dd2d 3.13.0-107-generic #154-Ubuntu SMP Tue Dec 20 09:57:27 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 6eba792
        Default Java 1.8.0_121
        findbugs v3.0.0
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/15501/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/15501/console
        Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        bibinchundatt Bibin A Chundatt added a comment - - edited

        Varun Saxena
        Thank you for looking into issue.. On second thought will add lock only in CommonNodeLabelsManager#addToCluserNodeLabels. Attaching patch after the change

        varun_saxena Varun Saxena added a comment -

        Thanks Bibin A Chundatt for the patch.
        You have added write locks in multiple methods of CommonNodeLabelsManager. But adding a write lock in only CommonNodeLabelsManager#addToCluserNodeLabels would be sufficient to fix this issue as for other node label operations come via RMNodeLabelManager which acquires the same write lock already.

        However, CommonNodeLabelsManager class if taken in isolation and the fact that its not an abstract class means that we can actually make the locking consistent there as well.
        So I am fine with what you have done in the patch.

        Let me look at the patch further in detail later today.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 21s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 13m 51s trunk passed
        +1 compile 0m 30s trunk passed
        +1 checkstyle 0m 22s trunk passed
        +1 mvnsite 0m 31s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 findbugs 1m 1s trunk passed
        +1 javadoc 0m 29s trunk passed
        +1 mvninstall 0m 29s the patch passed
        +1 compile 0m 27s the patch passed
        +1 javac 0m 27s the patch passed
        +1 checkstyle 0m 19s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common: The patch generated 0 new + 31 unchanged - 1 fixed = 31 total (was 32)
        +1 mvnsite 0m 29s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 12s the patch passed
        +1 javadoc 0m 27s the patch passed
        +1 unit 2m 24s hadoop-yarn-common in the patch passed.
        +1 asflicense 0m 18s The patch does not generate ASF License warnings.
        25m 1s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:a9ad5d6
        JIRA Issue YARN-6420
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12861583/YARN-6420.0001.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux d6bd501df566 3.13.0-105-generic #152-Ubuntu SMP Fri Dec 2 15:37:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 26172a9
        Default Java 1.8.0_121
        findbugs v3.0.0
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/15469/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/15469/console
        Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        bibinchundatt Bibin A Chundatt added a comment -

        We should consider this jira as candidate for 2.8.1 too.

        bibinchundatt Bibin A Chundatt added a comment -

        Varun Saxena

        So this can only happen if replace labels on node and adding of label is done parallely from 2 clients.
        And the order of events in dispatcher is reversed due to a potential race.

        Yes multiple clients could create race condition.We have to make sure events are inserted in order.

        varun_saxena Varun Saxena added a comment - - edited

        So this can only happen if replace labels on node and adding of label is done parallely from 2 clients.
        And the order of events in dispatcher is reversed due to a potential race.
        Right?

        bibinchundatt Bibin A Chundatt added a comment -

        We should have write lock for addToCluserNodeLabels , addToCluserNodeLabelsWithDefaultExclusivity addLabelsToNode


          People

          • Assignee:
            bibinchundatt Bibin A Chundatt
            Reporter:
            bibinchundatt Bibin A Chundatt
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development