Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-5728

TestMiniYarnClusterNodeUtilization.testUpdateNodeUtilization timeout

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-beta1, 2.8.2
    • Component/s: test
    • Labels:
      None

      Description

      TestMiniYARNClusterNodeUtilization.testUpdateNodeUtilization is failing by timeout.
      https://builds.apache.org/job/hadoop-qbt-trunk-java8-linux-x86/192/testReport/junit/org.apache.hadoop.yarn.server/TestMiniYarnClusterNodeUtilization/testUpdateNodeUtilization/

      java.lang.Exception: test timed out after 60000 milliseconds
      	at java.lang.Thread.sleep(Native Method)
      	at org.apache.hadoop.io.retry.RetryInvocationHandler$Call.processWaitTimeAndRetryInfo(RetryInvocationHandler.java:130)
      	at org.apache.hadoop.io.retry.RetryInvocationHandler$Call.invokeOnce(RetryInvocationHandler.java:107)
      	at org.apache.hadoop.io.retry.RetryInvocationHandler.invoke(RetryInvocationHandler.java:335)
      	at com.sun.proxy.$Proxy85.nodeHeartbeat(Unknown Source)
      	at org.apache.hadoop.yarn.server.TestMiniYarnClusterNodeUtilization.testUpdateNodeUtilization(TestMiniYarnClusterNodeUtilization.java:113)
      
      1. YARN-5728.001.patch
        2 kB
        Akira Ajisaka
      2. YARN-5728.002.patch
        2 kB
        Akira Ajisaka
      3. YARN-5728.01.patch
        1 kB
        Akira Ajisaka

        Issue Links

          Activity

          ajisakaa Akira Ajisaka added a comment -

          Committed this to trunk, branch-2, branch-2.8, and branch-2.8.2. Thanks Ray Chiang for the review.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #12075 (See https://builds.apache.org/job/Hadoop-trunk-Commit/12075/)
          YARN-5728. TestMiniYarnClusterNodeUtilization.testUpdateNodeUtilization (aajisaka: rev f8bed5e9a7d1ece127fb3da123bbfc26ada0016f)

          • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/MiniYARNCluster.java
          rchiang Ray Chiang added a comment -

          Sorry for the delay. The change looks fine to me. +1

          ajisakaa Akira Ajisaka added a comment -

          Hi Ray Chiang, would you please review this?

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 18s Docker mode activated.
                Prechecks
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
                trunk Compile Tests
          +1 mvninstall 14m 2s trunk passed
          +1 compile 0m 17s trunk passed
          +1 checkstyle 0m 12s trunk passed
          +1 mvnsite 0m 18s trunk passed
          0 findbugs 0m 0s Skipped patched modules with no Java source: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests
          +1 findbugs 0m 0s trunk passed
          +1 javadoc 0m 11s trunk passed
                Patch Compile Tests
          +1 mvninstall 0m 16s the patch passed
          +1 compile 0m 15s the patch passed
          +1 javac 0m 15s the patch passed
          +1 checkstyle 0m 10s the patch passed
          +1 mvnsite 0m 16s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          0 findbugs 0m 0s Skipped patched modules with no Java source: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests
          +1 findbugs 0m 0s the patch passed
          +1 javadoc 0m 8s the patch passed
                Other Tests
          +1 unit 2m 25s hadoop-yarn-server-tests in the patch passed.
          +1 asflicense 0m 19s The patch does not generate ASF License warnings.
          20m 4s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:14b5c93
          JIRA Issue YARN-5728
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12879127/YARN-5728.002.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux d5d2afc4fac2 3.13.0-119-generic #166-Ubuntu SMP Wed May 3 12:18:55 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 27a1a5f
          Default Java 1.8.0_131
          Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16572/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/16572/console
          Powered by Apache Yetus 0.6.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          002: fix grammar

          ajisakaa Akira Ajisaka added a comment -

          01 patch: Set hostname to "localhost" for MiniYARNCluster RM if the InetSocketAddress created by NetUtils.createSocketAddrForHost(hostname, port) is unresolved.

          ajisakaa Akira Ajisaka added a comment -

          Ran this test with some log levels raised. Probably this is the root cause.

          2017-07-27 06:49:49,715 INFO  [Thread-510] retry.RetryInvocationHandler (RetryInvocationHandler.java:invokeOnce(97)) - Call#-2: ResourceTracker.nodeHeartbeat([org.apache.hadoop.yarn.server.api.protocolrecords.impl.pb.NodeHeartbeatRequestPBImpl@721ff5c2])
          java.net.UnknownHostException: Invalid host name: local host is: (unknown); destination host is: "649448b35b66":36903; java.net.UnknownHostException; For more details see:  http://wiki.apache.org/hadoop/UnknownHost
                  at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
                  at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
                  at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
                  at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
                  at org.apache.hadoop.net.NetUtils.wrapWithMessage(NetUtils.java:815)
                  at org.apache.hadoop.net.NetUtils.wrapException(NetUtils.java:758)
                  at org.apache.hadoop.ipc.Client$Connection.<init>(Client.java:444)
                  at org.apache.hadoop.ipc.Client.getConnection(Client.java:1531)
                  at org.apache.hadoop.ipc.Client.call(Client.java:1382)
                  at org.apache.hadoop.ipc.Client.call(Client.java:1346)
                  at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:228)
                  at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:116)
                  at com.sun.proxy.$Proxy87.nodeHeartbeat(Unknown Source)
                  at org.apache.hadoop.yarn.server.api.impl.pb.client.ResourceTrackerPBClientImpl.nodeHeartbeat(ResourceTrackerPBClientImpl.java:85)
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                  at java.lang.reflect.Method.invoke(Method.java:498)
                  at org.apache.hadoop.io.retry.RetryInvocationHandler.invokeMethod(RetryInvocationHandler.java:410)
                  at org.apache.hadoop.io.retry.RetryInvocationHandler$Call.invokeMethod(RetryInvocationHandler.java:164)
                  at org.apache.hadoop.io.retry.RetryInvocationHandler$Call.invoke(RetryInvocationHandler.java:156)
                  at org.apache.hadoop.io.retry.RetryInvocationHandler$Call.invokeOnce(RetryInvocationHandler.java:95)
                  at org.apache.hadoop.io.retry.RetryInvocationHandler.invoke(RetryInvocationHandler.java:347)
                  at com.sun.proxy.$Proxy88.nodeHeartbeat(Unknown Source)
                  at org.apache.hadoop.yarn.server.TestMiniYarnClusterNodeUtilization.testUpdateNodeUtilization(TestMiniYarnClusterNodeUtilization.java:113)
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                  at java.lang.reflect.Method.invoke(Method.java:498)
                  at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
                  at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
                  at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
                  at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
                  at org.junit.internal.runners.statements.FailOnTimeout$StatementThread.run(FailOnTimeout.java:74)
          Caused by: java.net.UnknownHostException
                  at org.apache.hadoop.ipc.Client$Connection.<init>(Client.java:445)
                  ... 27 more
          

          This is very similar to YARN-6150. I'll attach a patch to fix this.

          ajisakaa Akira Ajisaka added a comment -

          I could reproduce this error locally by using Docker environment via start-build-env.sh. Now I'm investigating the root cause.

          Sonia Sonia Garudi added a comment -

          Any update on this? This still fails in trunk.

          ajisakaa Akira Ajisaka added a comment -

          Looks like extending the timeout does not fix this issue. Probably we need to find the root cause.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 22s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 1s The patch appears to include 1 new or modified test files.
          +1 mvninstall 7m 56s trunk passed
          +1 compile 0m 19s trunk passed
          +1 checkstyle 0m 14s trunk passed
          +1 mvnsite 0m 25s trunk passed
          +1 mvneclipse 0m 17s trunk passed
          +1 findbugs 0m 26s trunk passed
          +1 javadoc 0m 11s trunk passed
          +1 mvninstall 0m 18s the patch passed
          +1 compile 0m 16s the patch passed
          +1 javac 0m 16s the patch passed
          +1 checkstyle 0m 9s the patch passed
          +1 mvnsite 0m 21s the patch passed
          +1 mvneclipse 0m 15s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 0m 34s the patch passed
          +1 javadoc 0m 9s the patch passed
          -1 unit 8m 30s hadoop-yarn-server-tests in the patch failed.
          +1 asflicense 0m 20s The patch does not generate ASF License warnings.
          21m 41s



          Reason Tests
          Failed junit tests hadoop.yarn.server.TestContainerManagerSecurity
            hadoop.yarn.server.TestMiniYarnClusterNodeUtilization



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:9560f25
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12833048/YARN-5728.01.patch
          JIRA Issue YARN-5728
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 861f54be867a 3.13.0-96-generic #143-Ubuntu SMP Mon Aug 29 20:15:20 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 901eca0
          Default Java 1.8.0_101
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-YARN-Build/13373/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests.txt
          unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/13373/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests.txt
          Test Results https://builds.apache.org/job/PreCommit-YARN-Build/13373/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/13373/console
          Powered by Apache Yetus 0.3.0 http://yetus.apache.org

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          Very simple patch to extend the timeout to 5 minutes.


            People

            • Assignee:
              ajisakaa Akira Ajisaka
              Reporter:
              ajisakaa Akira Ajisaka
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development