Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-5432

Lock already held by another process while LevelDB cache store creation for dag

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.8.0, 2.7.3
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: timelineserver
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      While running ATS stress tests, 15 concurrent ATS reads (python thread which gives ws/v1/time/TEZ_DAG_ID, ws/v1/time/TEZ_VERTEX_DI?primaryFilter=TEZ_DAG_ID:<dag_id> etc) calls.

      Note: Summary store for ATSv1.5 is RLD, but as we for each dag/application ATS also creates leveldb cache when vertex/task/taskattempts information is queried from ATS.

      Getting following type of excpetion very frequently in ATS logs :-
      2016-07-23 00:01:56,089 [1517798697@qtp-1198158701-850] INFO org.apache.hadoop.service.AbstractService: Service LeveldbCache.timelineEntityGroupId_1469090881194_4832_application_1469090881194_4832 failed in state INITED; cause: org.fusesource.leveldbjni.internal.NativeDB$DBException: IO error: lock /grid/4/yarn_ats/atsv15_rld/timelineEntityGroupId_1469090881194_4832_application_1469090881194_4832-timeline-cache.ldb/LOCK: already held by process
      org.fusesource.leveldbjni.internal.NativeDB$DBException: IO error: lock /grid/4/yarn_ats/atsv15_rld/timelineEntityGroupId_1469090881194_4832_application_1469090881194_4832-timeline-cache.ldb/LOCK: already held by process
      at org.fusesource.leveldbjni.internal.NativeDB.checkStatus(NativeDB.java:200)
      at org.fusesource.leveldbjni.internal.NativeDB.open(NativeDB.java:218)
      at org.fusesource.leveldbjni.JniDBFactory.open(JniDBFactory.java:168)
      at org.apache.hadoop.yarn.server.timeline.LevelDBCacheTimelineStore.serviceInit(LevelDBCacheTimelineStore.java:108)
      at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
      at org.apache.hadoop.yarn.server.timeline.EntityCacheItem.refreshCache(EntityCacheItem.java:113)
      at org.apache.hadoop.yarn.server.timeline.EntityGroupFSTimelineStore.getCachedStore(EntityGroupFSTimelineStore.java:1021)
      at org.apache.hadoop.yarn.server.timeline.EntityGroupFSTimelineStore.getTimelineStoresFromCacheIds(EntityGroupFSTimelineStore.java:936)
      at org.apache.hadoop.yarn.server.timeline.EntityGroupFSTimelineStore.getTimelineStoresForRead(EntityGroupFSTimelineStore.java:989)
      at org.apache.hadoop.yarn.server.timeline.EntityGroupFSTimelineStore.getEntities(EntityGroupFSTimelineStore.java:1041)
      at org.apache.hadoop.yarn.server.timeline.TimelineDataManager.doGetEntities(TimelineDataManager.java:168)
      at org.apache.hadoop.yarn.server.timeline.TimelineDataManager.getEntities(TimelineDataManager.java:138)
      at org.apache.hadoop.yarn.server.timeline.webapp.TimelineWebServices.getEntities(TimelineWebServices.java:117)
      at sun.reflect.GeneratedMethodAccessor82.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:498)
      at com.sun.jersey.spi.container.JavaMethodInvokerFactory$1.invoke(JavaMethodInvokerFactory.java:60)
      at com.sun.jersey.server.impl.model.method.dispatch.AbstractResourceMethodDispatchProvider$TypeOutInvoker._dispatch(AbstractResourceMethodDispatchProvider.java:185)
      at com.sun.jersey.server.impl.model.method.dispatch.ResourceJavaMethodDispatcher.dispatch(ResourceJavaMethodDispatcher.java:75)
      at com.sun.jersey.server.impl.uri.rules.HttpMethodRule.accept(HttpMethodRule.java:288)
      at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
      at com.sun.jersey.server.impl.uri.rules.ResourceClassRule.accept(ResourceClassRule.java:108)
      at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
      at com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule.accept(RootResourceClassesRule.java:84)
      at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1469)
      at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1400)
      at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1349)
      at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1339)
      at com.sun.jersey.spi.container.servlet.WebComponent.service(WebComponent.java:416)
      at com.sun.jersey.spi.container.servlet.ServletContainer.service(ServletContainer.java:537)
      at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:886)
      at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:834)
      at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:795)
      at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163)
      at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58)
      at com.google.inject.servlet.ManagedFilterPipeline.dispatch(ManagedFilterPipeline.java:118)
      at com.google.inject.servlet.GuiceFilter.doFilter(GuiceFilter.java:113)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
      at org.apache.hadoop.security.http.XFrameOptionsFilter.doFilter(XFrameOptionsFilter.java:57)

      1. YARN-5432-trunk.001.patch
        6 kB
        Li Lu
      2. YARN-5432-trunk.002.patch
        15 kB
        Li Lu
      3. YARN-5432-trunk.003.patch
        16 kB
        Li Lu

        Activity

        gtCarrera9 Li Lu added a comment -

        Thanks for reporting this issue Karam Singh!

        The main cause of this issue is that after concurrency changes in YARN-4987, it is possible for readers to hold a cache item from being released. If during this period another read request to the same entity group id occurs, the storage will try to create a new cache on the same file location. This will cause the locking issue on the leveldb. This also explains why the problem is severe when cache size is small and reader contention is high: with smaller cache sizes, cache evictions are more frequent. At the same time, higher reader contention will introduce higher chances for readers to "hold" a cache storage.

        gtCarrera9 Li Lu added a comment -

        Upload a patch to fix this issue. It fixes the problems on two sides: 1. using a creation timestamp in the leveldb cache store's db name, therefore caches pointing to the same group id will have unique names even if the old cache has been evicted. 2. Perform precondition check on the cache size to avoid the ATS v1.5 store runs with 0 caches.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 17s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 0s trunk passed
        +1 compile 0m 15s trunk passed
        +1 checkstyle 0m 12s trunk passed
        +1 mvnsite 0m 19s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 0m 24s trunk passed
        +1 javadoc 0m 12s trunk passed
        +1 mvninstall 0m 13s the patch passed
        +1 compile 0m 13s the patch passed
        +1 javac 0m 13s the patch passed
        +1 checkstyle 0m 8s the patch passed
        +1 mvnsite 0m 16s the patch passed
        +1 mvneclipse 0m 10s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 27s the patch passed
        +1 javadoc 0m 10s the patch passed
        +1 unit 1m 17s hadoop-yarn-server-timeline-pluginstorage in the patch passed.
        +1 asflicense 0m 14s The patch does not generate ASF License warnings.
        12m 37s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12820226/YARN-5432-trunk.001.patch
        JIRA Issue YARN-5432
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 1975846e70c5 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / da6adf5
        Default Java 1.8.0_101
        findbugs v3.0.0
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/12507/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-timeline-pluginstorage U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-timeline-pluginstorage
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/12507/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        gtCarrera9 Li Lu added a comment -

        Had some offline discussion with Junping Du. Seems we're on a track of overcomplicating problems. The problem reported in YARN-4987 only occurs when the app cache is too small, and we limit the size of the app cache to control the memory usage upper bound of the ATS reader. So, instead of using refcounts and handle corner cases like the one reported here, another solution is to insist on the app cache size. We also make it clear in the config's description about the potential effect of setting a cache size that is too small.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 24s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        0 mvndep 0m 10s Maven dependency ordering for branch
        +1 mvninstall 6m 48s trunk passed
        +1 compile 2m 16s trunk passed
        +1 checkstyle 0m 39s trunk passed
        +1 mvnsite 0m 53s trunk passed
        +1 mvneclipse 0m 26s trunk passed
        +1 findbugs 1m 23s trunk passed
        +1 javadoc 0m 41s trunk passed
        0 mvndep 0m 9s Maven dependency ordering for patch
        +1 mvninstall 0m 42s the patch passed
        +1 compile 2m 19s the patch passed
        +1 javac 2m 19s the patch passed
        -1 checkstyle 0m 37s hadoop-yarn-project/hadoop-yarn: The patch generated 8 new + 6 unchanged - 0 fixed = 14 total (was 6)
        +1 mvnsite 0m 46s the patch passed
        +1 mvneclipse 0m 25s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 xml 0m 2s The patch has no ill-formed XML file.
        +1 findbugs 1m 28s the patch passed
        +1 javadoc 0m 47s the patch passed
        +1 unit 2m 22s hadoop-yarn-common in the patch passed.
        +1 unit 1m 14s hadoop-yarn-server-timeline-pluginstorage in the patch passed.
        +1 asflicense 0m 17s The patch does not generate ASF License warnings.
        25m 37s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12820313/YARN-5432-trunk.002.patch
        JIRA Issue YARN-5432
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml findbugs checkstyle
        uname Linux 877fcdc395d0 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / d84ab8a
        Default Java 1.8.0_101
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/12513/artifact/patchprocess/diff-checkstyle-hadoop-yarn-project_hadoop-yarn.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/12513/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-timeline-pluginstorage U: hadoop-yarn-project/hadoop-yarn
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/12513/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        gtCarrera9 Li Lu added a comment -

        Fix checkstyle issues.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 17s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        0 mvndep 0m 27s Maven dependency ordering for branch
        +1 mvninstall 7m 25s trunk passed
        +1 compile 2m 31s trunk passed
        +1 checkstyle 0m 37s trunk passed
        +1 mvnsite 0m 49s trunk passed
        +1 mvneclipse 0m 26s trunk passed
        +1 findbugs 1m 19s trunk passed
        +1 javadoc 0m 39s trunk passed
        0 mvndep 0m 9s Maven dependency ordering for patch
        +1 mvninstall 0m 38s the patch passed
        +1 compile 2m 14s the patch passed
        +1 javac 2m 14s the patch passed
        +1 checkstyle 0m 35s the patch passed
        +1 mvnsite 0m 44s the patch passed
        +1 mvneclipse 0m 21s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 xml 0m 2s The patch has no ill-formed XML file.
        +1 findbugs 1m 28s the patch passed
        +1 javadoc 0m 34s the patch passed
        +1 unit 2m 16s hadoop-yarn-common in the patch passed.
        +1 unit 1m 12s hadoop-yarn-server-timeline-pluginstorage in the patch passed.
        +1 asflicense 0m 18s The patch does not generate ASF License warnings.
        25m 48s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12820323/YARN-5432-trunk.003.patch
        JIRA Issue YARN-5432
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml findbugs checkstyle
        uname Linux 6775b38127f9 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / d84ab8a
        Default Java 1.8.0_101
        findbugs v3.0.0
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/12514/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-timeline-pluginstorage U: hadoop-yarn-project/hadoop-yarn
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/12514/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        djp Junping Du added a comment -

        So, instead of using refcounts and handle corner cases like the one reported here, another solution is to insist on the app cache size.

        +1. KISS (keep it simple & stupid) rules still works here.

        003 patch LGTM. Will commit it later today if not further comments from others.

        djp Junping Du added a comment -

        I have commit the patch to trunk, branch-2 and branch-2.8. Thanks Li Lu for the patch contribution!

        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-trunk-Commit #10168 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10168/)
        YARN-5432. Lock already held by another process while LevelDB cache (junping_du: rev 7f3c306e2ed9e865171324898decb9b587d90e73)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-timeline-pluginstorage/src/main/java/org/apache/hadoop/yarn/server/timeline/EntityCacheItem.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/main/resources/yarn-default.xml
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-timeline-pluginstorage/src/main/java/org/apache/hadoop/yarn/server/timeline/EntityGroupFSTimelineStore.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-timeline-pluginstorage/src/test/java/org/apache/hadoop/yarn/server/timeline/TestEntityGroupFSTimelineStore.java

          People

          • Assignee:
            gtCarrera9 Li Lu
            Reporter:
            karams Karam Singh
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development