VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Reviewed

    Description

      When querying the REST API, I find that the created time value is returned as "0" for most of the output. It includes:

      • flow activity and flow runs in the flow activity page
      • apps in the application page
      • entities in the entity page

      For example, in the flow activity page,

      {
      metrics: [ ],
      events: [ ],
      id: "yarn_cluster/1463356800000/sjlee@ds-date",
      type: "YARN_FLOW_ACTIVITY",
      createdtime: 0,
      flowruns: [
      {
      metrics: [ ],
      events: [ ],
      id: "sjlee@ds-date/1463435661428",
      type: "YARN_FLOW_RUN",
      createdtime: 0,
      info: {
      SYSTEM_INFO_FLOW_VERSION: "1",
      SYSTEM_INFO_FLOW_RUN_ID: 1463435661428,
      SYSTEM_INFO_FLOW_NAME: "ds-date",
      SYSTEM_INFO_USER: "sjlee"
      },
      isrelatedto: { },
      relatesto: { }
      }
      ],
      info: {
      SYSTEM_INFO_CLUSTER: "yarn_cluster",
      UID: "yarn_cluster!sjlee!ds-date",
      SYSTEM_INFO_FLOW_NAME: "ds-date",
      SYSTEM_INFO_DATE: 1463356800000,
      SYSTEM_INFO_USER: "sjlee"
      },
      isrelatedto: { },
      relatesto: { }
      }
      

      The only page that appears to show the proper created time value is the flow run page.

      Attachments

        1. YARN-5093-YARN-2928.01.patch
          15 kB
          Varun Saxena

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            varun_saxena Varun Saxena
            sjlee0 Sangjin Lee
            Votes:
            0 Vote for this issue
            Watchers:
            9 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Issue deployment