Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-5020

Fix Documentation for Yarn Capacity Scheduler on Resource Calculator

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      Documentation refers to 'DefaultResourseCalculator' - which is spelled incorrectly.

      1. YARN-5020.1.patch
        1 kB
        Takashi Ohnishi

        Activity

        jo_desmet@yahoo.com Jo Desmet added a comment -

        Documentation on Yarn Hadoop, ex https://hadoop.apache.org/docs/r2.6.0/hadoop-yarn/hadoop-yarn-site/CapacityScheduler.html

        Under the configuration section, other properties, resource calculator, it refers to 'DefaultResourseCalculator' Which should spell as 'DefaultResourceCalculator' instead. If not fixed, copy past of this classname in your properties, could lead to misconfiguration or failure.

        bwtakacy Takashi Ohnishi added a comment -

        Hi.

        I have created a patch for this typo.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 11s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 mvninstall 6m 32s trunk passed
        +1 mvnsite 0m 14s trunk passed
        +1 mvnsite 0m 12s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 asflicense 0m 18s Patch does not generate ASF License warnings.
        7m 42s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:cf2ee45
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12802665/YARN-5020.1.patch
        JIRA Issue YARN-5020
        Optional Tests asflicense mvnsite
        uname Linux bc7071962f0d 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 2835f14
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/11362/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        jo_desmet@yahoo.com Jo Desmet added a comment -

        Thanks after patch - reads as intended.

        jianhe Jian He added a comment -

        Committed to trunk, branch-2, branch-2.8.

        Thanks Takashi Ohnishi !
        Thanks Jo Desmet for reporting this.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-trunk-Commit #9834 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9834/)
        YARN-5020. Fix Documentation for Yarn Capacity Scheduler on Resource (jianhe: rev d364ceac85622e99133b3eb3becef0c8188e6f89)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-site/src/site/markdown/CapacityScheduler.md
        bwtakacy Takashi Ohnishi added a comment -

        Thanks Jian He for committing!


          People

          • Assignee:
            bwtakacy Takashi Ohnishi
            Reporter:
            jo_desmet@yahoo.com Jo Desmet
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development