Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-4965

Distributed shell AM failed due to ClientHandlerException thrown by jersey

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.7.2
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      Distributed shell AM failed with RuntimeException: ClientHandlerException

      app logs
      Exception in thread "AMRM Callback Handler Thread" org.apache.hadoop.yarn.exceptions.YarnRuntimeException: com.sun.jersey.api.client.ClientHandlerException: java.io.IOException: Stream closed.
      	at org.apache.hadoop.yarn.client.api.async.impl.AMRMClientAsyncImpl$CallbackHandlerThread.run(AMRMClientAsyncImpl.java:312)
      Caused by: com.sun.jersey.api.client.ClientHandlerException: java.io.IOException: Stream closed.
      	at com.sun.jersey.api.client.ClientResponse.getEntity(ClientResponse.java:563)
      	at com.sun.jersey.api.client.ClientResponse.getEntity(ClientResponse.java:506)
      	at org.apache.hadoop.yarn.client.api.impl.TimelineClientImpl.putEntities(TimelineClientImpl.java:446)
      	at org.apache.hadoop.yarn.applications.distributedshell.ApplicationMaster.publishContainerEndEvent(ApplicationMaster.java:1144)
      	at org.apache.hadoop.yarn.applications.distributedshell.ApplicationMaster.access$400(ApplicationMaster.java:169)
      	at org.apache.hadoop.yarn.applications.distributedshell.ApplicationMaster$RMCallbackHandler.onContainersCompleted(ApplicationMaster.java:779)
      	at org.apache.hadoop.yarn.client.api.async.impl.AMRMClientAsyncImpl$CallbackHandlerThread.run(AMRMClientAsyncImpl.java:300)
      Caused by: java.io.IOException: Stream closed.
      	at java.net.AbstractPlainSocketImpl.available(AbstractPlainSocketImpl.java:458)
      	at java.net.SocketInputStream.available(SocketInputStream.java:245)
      	at java.io.BufferedInputStream.read(BufferedInputStream.java:342)
      	at sun.net.www.http.ChunkedInputStream.readAheadBlocking(ChunkedInputStream.java:552)
      	at sun.net.www.http.ChunkedInputStream.readAhead(ChunkedInputStream.java:609)
      	at sun.net.www.http.ChunkedInputStream.read(ChunkedInputStream.java:696)
      	at java.io.FilterInputStream.read(FilterInputStream.java:133)
      	at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3067)
      	at org.codehaus.jackson.impl.ByteSourceBootstrapper.ensureLoaded(ByteSourceBootstrapper.java:507)
      	at org.codehaus.jackson.impl.ByteSourceBootstrapper.detectEncoding(ByteSourceBootstrapper.java:129)
      	at org.codehaus.jackson.impl.ByteSourceBootstrapper.constructParser(ByteSourceBootstrapper.java:224)
      	at org.codehaus.jackson.JsonFactory._createJsonParser(JsonFactory.java:785)
      	at org.codehaus.jackson.JsonFactory.createJsonParser(JsonFactory.java:561)
      	at org.codehaus.jackson.jaxrs.JacksonJsonProvider.readFrom(JacksonJsonProvider.java:414)
      	at com.sun.jersey.api.client.ClientResponse.getEntity(ClientResponse.java:553)
      	... 6 more
      

        Activity

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 10s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
        0 mvndep 0m 14s Maven dependency ordering for branch
        +1 mvninstall 6m 28s trunk passed
        +1 compile 5m 38s trunk passed with JDK v1.8.0_77
        +1 compile 6m 32s trunk passed with JDK v1.7.0_95
        +1 checkstyle 1m 7s trunk passed
        +1 mvnsite 1m 17s trunk passed
        +1 mvneclipse 0m 39s trunk passed
        +1 findbugs 2m 19s trunk passed
        +1 javadoc 0m 53s trunk passed with JDK v1.8.0_77
        +1 javadoc 1m 3s trunk passed with JDK v1.7.0_95
        0 mvndep 0m 13s Maven dependency ordering for patch
        +1 mvninstall 1m 4s the patch passed
        +1 compile 5m 32s the patch passed with JDK v1.8.0_77
        +1 javac 5m 32s the patch passed
        +1 compile 6m 31s the patch passed with JDK v1.7.0_95
        +1 javac 6m 31s the patch passed
        -1 checkstyle 1m 7s root: patch generated 1 new + 366 unchanged - 5 fixed = 367 total (was 371)
        +1 mvnsite 1m 17s the patch passed
        +1 mvneclipse 0m 39s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 xml 0m 1s The patch has no ill-formed XML file.
        +1 findbugs 2m 54s the patch passed
        +1 javadoc 0m 52s the patch passed with JDK v1.8.0_77
        +1 javadoc 1m 2s the patch passed with JDK v1.7.0_95
        +1 unit 1m 52s hadoop-yarn-common in the patch passed with JDK v1.8.0_77.
        +1 unit 7m 13s hadoop-yarn-applications-distributedshell in the patch passed with JDK v1.8.0_77.
        +1 unit 9m 2s hadoop-mapreduce-client-app in the patch passed with JDK v1.8.0_77.
        +1 unit 2m 9s hadoop-yarn-common in the patch passed with JDK v1.7.0_95.
        +1 unit 7m 29s hadoop-yarn-applications-distributedshell in the patch passed with JDK v1.7.0_95.
        +1 unit 9m 33s hadoop-mapreduce-client-app in the patch passed with JDK v1.7.0_95.
        +1 asflicense 0m 22s Patch does not generate ASF License warnings.
        86m 43s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:fbe3e86
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12799063/YARN-4965.patch
        JIRA Issue YARN-4965
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle xml
        uname Linux 6c44b2687a37 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / cab9cba
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/11112/artifact/patchprocess/diff-checkstyle-root.txt
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/11112/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app U: .
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/11112/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        djp Junping Du added a comment -

        The checkstyle issue is not related to the patch.

        xgong Xuan Gong added a comment -

        +1 lgtm. checking this in

        xgong Xuan Gong added a comment -

        Committed into trunk/branch-2/branch-2.8. Thanks, Junping for the fix. And Thanks Sumana for reporting this issue.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #9623 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9623/)
        YARN-4965. Distributed shell AM failed due to ClientHandlerException (xgong: rev e6c0742012ffeacad2bcaf712d86a7e5d1420b26)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/ApplicationMaster.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/test/java/org/apache/hadoop/yarn/client/api/impl/TestTimelineClient.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/jobhistory/JobHistoryEventHandler.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        djp Junping Du added a comment -

        Thanks Xuan for review and commit!


          People

          • Assignee:
            djp Junping Du
            Reporter:
            ssathish@hortonworks.com Sumana Sathish
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development