Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-4938

MiniYarnCluster should not request transitionToActive to RM on non-HA environment

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 2.7.3, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      TestMRJobs#testJobWithChangePriority fails.

      Running org.apache.hadoop.mapreduce.v2.TestMRJobs
      Tests run: 12, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 446.855 sec <<< FAILURE! - in org.apache.hadoop.mapreduce.v2.TestMRJobs
      testJobWithChangePriority(org.apache.hadoop.mapreduce.v2.TestMRJobs)  Time elapsed: 21.477 sec  <<< FAILURE!
      java.lang.AssertionError: expected:<DEFAULT> but was:<HIGH>
      	at org.junit.Assert.fail(Assert.java:88)
      	at org.junit.Assert.failNotEquals(Assert.java:743)
      	at org.junit.Assert.assertEquals(Assert.java:118)
      	at org.junit.Assert.assertEquals(Assert.java:144)
      	at org.apache.hadoop.mapreduce.v2.TestMRJobs.testJobWithChangePriority(TestMRJobs.java:276)
      

        Issue Links

          Activity

          vinodkv Vinod Kumar Vavilapalli added a comment -

          Closing the JIRA as part of 2.7.3 release.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #9588 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9588/)
          YARN-4938. MiniYarnCluster should not request transitionToActive to RM (aajisaka: rev 1b78b2ba17cffdd19ae056555dd7f89b7a3eb06a)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/MiniYARNCluster.java
          ajisakaa Akira Ajisaka added a comment -

          Committed this to trunk, branch-2, branch-2.8, and branch-2.7. Thanks Eric for the contribution!

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 14s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 6m 37s trunk passed
          +1 compile 0m 14s trunk passed with JDK v1.8.0_77
          +1 compile 0m 16s trunk passed with JDK v1.7.0_95
          +1 checkstyle 0m 14s trunk passed
          +1 mvnsite 0m 20s trunk passed
          +1 mvneclipse 0m 15s trunk passed
          +1 findbugs 0m 27s trunk passed
          +1 javadoc 0m 14s trunk passed with JDK v1.8.0_77
          +1 javadoc 0m 17s trunk passed with JDK v1.7.0_95
          +1 mvninstall 0m 16s the patch passed
          +1 compile 0m 11s the patch passed with JDK v1.8.0_77
          +1 javac 0m 11s the patch passed
          +1 compile 0m 14s the patch passed with JDK v1.7.0_95
          +1 javac 0m 14s the patch passed
          +1 checkstyle 0m 10s the patch passed
          +1 mvnsite 0m 18s the patch passed
          +1 mvneclipse 0m 12s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 0m 36s the patch passed
          +1 javadoc 0m 11s the patch passed with JDK v1.8.0_77
          +1 javadoc 0m 15s the patch passed with JDK v1.7.0_95
          -1 unit 6m 44s hadoop-yarn-server-tests in the patch failed with JDK v1.8.0_77.
          -1 unit 6m 52s hadoop-yarn-server-tests in the patch failed with JDK v1.7.0_95.
          +1 asflicense 0m 17s Patch does not generate ASF License warnings.
          26m 23s



          Reason Tests
          JDK v1.8.0_77 Failed junit tests hadoop.yarn.server.TestContainerManagerSecurity
            hadoop.yarn.server.TestMiniYarnClusterNodeUtilization
          JDK v1.7.0_95 Failed junit tests hadoop.yarn.server.TestContainerManagerSecurity
            hadoop.yarn.server.TestMiniYarnClusterNodeUtilization



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:fbe3e86
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12797375/MAPREDUCE-6658.001.patch
          JIRA Issue YARN-4938
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux c5c005fa437b 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / ff95fd5
          Default Java 1.7.0_95
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-YARN-Build/11014/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.8.0_77.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/11014/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.7.0_95.txt
          unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/11014/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.8.0_77.txt https://builds.apache.org/job/PreCommit-YARN-Build/11014/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.7.0_95.txt
          JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/11014/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/11014/console
          Powered by Apache Yetus 0.2.0 http://yetus.apache.org

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          Moved to YARN project because the fix is in MiniYarnCluster.

          ajisakaa Akira Ajisaka added a comment -

          Thanks Eric Badger for tracking down the cause. +1, manually verified that the patch fixes the test.

          ebadger Eric Badger added a comment -

          TestContainerManagerSecurity is tracked by YARN-4342. Sorry for the typo.

          ebadger Eric Badger added a comment -

          TestMiniYarnClusterNodeUtilization is tracked by YARN-4453

          TestMiniYarnClusterNodeUtilization is tracked by YARN-4342

          It concerns me a little bit that both of these tests failed twice in a row with the addition of my patch. However, I am unable to reproduce the failure on my local Mac or Linux boxes, even under high-cpu situations (similar to Jenkins).

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 14m 53s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 11m 24s trunk passed
          +1 compile 0m 20s trunk passed with JDK v1.8.0_77
          +1 compile 0m 19s trunk passed with JDK v1.7.0_95
          +1 checkstyle 0m 22s trunk passed
          +1 mvnsite 0m 27s trunk passed
          +1 mvneclipse 0m 23s trunk passed
          +1 findbugs 0m 43s trunk passed
          +1 javadoc 0m 21s trunk passed with JDK v1.8.0_77
          +1 javadoc 0m 20s trunk passed with JDK v1.7.0_95
          +1 mvninstall 0m 20s the patch passed
          +1 compile 0m 17s the patch passed with JDK v1.8.0_77
          +1 javac 0m 17s the patch passed
          +1 compile 0m 17s the patch passed with JDK v1.7.0_95
          +1 javac 0m 17s the patch passed
          +1 checkstyle 0m 12s the patch passed
          +1 mvnsite 0m 21s the patch passed
          +1 mvneclipse 0m 16s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 0m 42s the patch passed
          +1 javadoc 0m 17s the patch passed with JDK v1.8.0_77
          +1 javadoc 0m 18s the patch passed with JDK v1.7.0_95
          -1 unit 6m 48s hadoop-yarn-server-tests in the patch failed with JDK v1.8.0_77.
          -1 unit 6m 45s hadoop-yarn-server-tests in the patch failed with JDK v1.7.0_95.
          +1 asflicense 0m 23s Patch does not generate ASF License warnings.
          47m 37s



          Reason Tests
          JDK v1.8.0_77 Failed junit tests hadoop.yarn.server.TestMiniYarnClusterNodeUtilization
            hadoop.yarn.server.TestContainerManagerSecurity
          JDK v1.7.0_95 Failed junit tests hadoop.yarn.server.TestMiniYarnClusterNodeUtilization
            hadoop.yarn.server.TestContainerManagerSecurity



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:fbe3e86
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12797375/MAPREDUCE-6658.001.patch
          JIRA Issue MAPREDUCE-6658
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 1fd466d06daf 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / ce5b481
          Default Java 1.7.0_95
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6422/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.8.0_77.txt
          unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6422/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.7.0_95.txt
          unit test logs https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6422/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.8.0_77.txt https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6422/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.7.0_95.txt
          JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6422/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests
          Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6422/console
          Powered by Apache Yetus 0.2.0 http://yetus.apache.org

          This message was automatically generated.

          ebadger Eric Badger added a comment -

          Eric Payne, Jason Lowe, Karthik Kambatla, can one of you review this patch? It's a very small change that will fix some recurring test failures.

          ebadger Eric Badger added a comment -

          Neither of these test failures are reproducible on my local machine with the patch applied.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 24s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 6m 51s trunk passed
          +1 compile 0m 16s trunk passed with JDK v1.8.0_77
          +1 compile 0m 16s trunk passed with JDK v1.7.0_95
          +1 checkstyle 0m 14s trunk passed
          +1 mvnsite 0m 21s trunk passed
          +1 mvneclipse 0m 16s trunk passed
          +1 findbugs 0m 28s trunk passed
          +1 javadoc 0m 15s trunk passed with JDK v1.8.0_77
          +1 javadoc 0m 17s trunk passed with JDK v1.7.0_95
          +1 mvninstall 0m 17s the patch passed
          +1 compile 0m 12s the patch passed with JDK v1.8.0_77
          +1 javac 0m 12s the patch passed
          +1 compile 0m 14s the patch passed with JDK v1.7.0_95
          +1 javac 0m 14s the patch passed
          +1 checkstyle 0m 10s the patch passed
          +1 mvnsite 0m 20s the patch passed
          +1 mvneclipse 0m 11s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 0m 35s the patch passed
          +1 javadoc 0m 12s the patch passed with JDK v1.8.0_77
          +1 javadoc 0m 15s the patch passed with JDK v1.7.0_95
          -1 unit 6m 46s hadoop-yarn-server-tests in the patch failed with JDK v1.8.0_77.
          -1 unit 6m 51s hadoop-yarn-server-tests in the patch failed with JDK v1.7.0_95.
          +1 asflicense 0m 18s Patch does not generate ASF License warnings.
          26m 59s



          Reason Tests
          JDK v1.8.0_77 Failed junit tests hadoop.yarn.server.TestContainerManagerSecurity
            hadoop.yarn.server.TestMiniYarnClusterNodeUtilization
          JDK v1.7.0_95 Failed junit tests hadoop.yarn.server.TestContainerManagerSecurity
            hadoop.yarn.server.TestMiniYarnClusterNodeUtilization



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:fbe3e86
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12797375/MAPREDUCE-6658.001.patch
          JIRA Issue MAPREDUCE-6658
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 179b231d133f 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / aede8c1
          Default Java 1.7.0_95
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6418/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.8.0_77.txt
          unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6418/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.7.0_95.txt
          unit test logs https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6418/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.8.0_77.txt https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6418/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-tests-jdk1.7.0_95.txt
          JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6418/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests
          Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6418/console
          Powered by Apache Yetus 0.2.0 http://yetus.apache.org

          This message was automatically generated.

          ebadger Eric Badger added a comment -

          Akira Ajisaka, I tracked down the issue. Indeed, it was my code that broke the tests. I'm not sure why I wasn't able to reproduce the failures consistently, but maybe that was another side effect of my earlier changes. The bug was that the MiniYARNCluster was explicitly calling transitionToActive on the resource manager with index 0. This overwrote some conf properties and reset the cluster max priority property back to DEFAULT.

          I'm attaching a patch that fixes this issue by only transition the RM with index 0 to active if we are in an HA cluster.

          ebadger Eric Badger added a comment -

          I believe that there is a race condition that causes this bug to appear and disappear with the addition of YARN-4686. However, there is another race condition (possibly the same one) that forces the test to fail in the cases both with and without YARN-4686. Earlier today I was able to get the test to fail with the patch and not without it. But now it fails whether the patch is there or not and this happens to me on both of my machines (both unix and linux). I haven't figured out where the race(s) is/are occurring yet, but I believe that they will shed light onto why the tests are failing sporadically for me.

          ebadger Eric Badger added a comment -

          Not quite sure what has changed since yesterday, but I am now able to consistently reproduce the failure. I will look into this issue.

          ajisakaa Akira Ajisaka added a comment -

          I verified this was broken by YARN-4686 by running these commands:

          (before YARN-4686)
          $ git checkout 9b623fbaf79c0f854abc6b4a0539d4ea8c93dc1a
          $ mvn clean
          $ mvn test -Dtest=TestMRJobs#testJobWithChangePriority
          

          The test suceeded.

          (after YARN-4686)
          $ git checkout 92b7e0d41302b6b110927f99de5c2b4a4a93c5fd
          $ mvn clean
          $ mvn test -Dtest=TestMRJobs#testJobWithChangePriority
          

          The test failed.

          ebadger Eric Badger added a comment -

          Akira Ajisaka are you sure this was broken by YARN-4686? I checked out trunk all the back to the end of February and this test failed every time in the same way as you have shown above.

          ajisakaa Akira Ajisaka added a comment -

          I ran git bisect and found that YARN-4686 broke the test.


            People

            • Assignee:
              ebadger Eric Badger
              Reporter:
              ajisakaa Akira Ajisaka
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development