Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-4605

Spelling mistake in the help message of "yarn applicationattempt" command

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.4.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: client, yarn
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Using YARN CLI, when the user types "yarn applicationattempt", the help message for the "applicationattempt" command is shown.

      Here, the following line has a spelling mistake. "application" is misspelled as "aplication":

      -list <Application ID> List application attempts for aplication.

      1. YARN-4605.001.patch
        8 kB
        Weiwei Yang
      2. YARN-4605.002.patch
        8 kB
        Weiwei Yang
      3. YARN-4605.003.patch
        6 kB
        Weiwei Yang

        Issue Links

          Activity

          cheersyang Weiwei Yang added a comment -

          I do see several places having such typo, changes is trivial, just submitted a patch to fix this.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
          0 mvndep 0m 55s Maven dependency ordering for branch
          +1 mvninstall 7m 49s trunk passed
          +1 compile 6m 2s trunk passed with JDK v1.8.0_66
          +1 compile 6m 52s trunk passed with JDK v1.7.0_91
          +1 checkstyle 1m 1s trunk passed
          +1 mvnsite 1m 24s trunk passed
          +1 mvneclipse 0m 42s trunk passed
          +1 findbugs 2m 17s trunk passed
          +1 javadoc 0m 50s trunk passed with JDK v1.8.0_66
          +1 javadoc 1m 3s trunk passed with JDK v1.7.0_91
          0 mvndep 0m 25s Maven dependency ordering for patch
          +1 mvninstall 1m 8s the patch passed
          +1 compile 5m 56s the patch passed with JDK v1.8.0_66
          +1 javac 5m 56s the patch passed
          +1 compile 7m 5s the patch passed with JDK v1.7.0_91
          +1 javac 7m 5s the patch passed
          +1 checkstyle 0m 57s the patch passed
          +1 mvnsite 1m 24s the patch passed
          +1 mvneclipse 0m 42s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 55s the patch passed
          +1 javadoc 0m 49s the patch passed with JDK v1.8.0_66
          +1 javadoc 1m 1s the patch passed with JDK v1.7.0_91
          -1 unit 60m 25s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.8.0_66.
          -1 unit 64m 17s hadoop-yarn-client in the patch failed with JDK v1.8.0_66.
          -1 unit 64m 19s hadoop-yarn-client in the patch failed with JDK v1.8.0_66.
          -1 unit 61m 29s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.7.0_91.
          -1 unit 64m 27s hadoop-yarn-client in the patch failed with JDK v1.7.0_91.
          -1 unit 64m 29s hadoop-yarn-client in the patch failed with JDK v1.7.0_91.
          +1 asflicense 0m 23s Patch does not generate ASF License warnings.
          432m 45s



          Reason Tests
          JDK v1.8.0_66 Failed junit tests hadoop.yarn.server.resourcemanager.TestClientRMTokens
            hadoop.yarn.server.resourcemanager.TestAMAuthorization
            hadoop.yarn.client.TestGetGroups
            hadoop.yarn.client.TestGetGroups
          JDK v1.8.0_66 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient
            org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient
          JDK v1.7.0_91 Failed junit tests hadoop.yarn.server.resourcemanager.TestClientRMTokens
            hadoop.yarn.server.resourcemanager.TestAMAuthorization
            hadoop.yarn.client.TestGetGroups
            hadoop.yarn.client.TestGetGroups
          JDK v1.7.0_91 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient
            org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12783024/YARN-4605.001.patch
          JIRA Issue YARN-4605
          Optional Tests asflicense mvnsite compile javac javadoc mvninstall unit findbugs checkstyle
          uname Linux 9fefae8a78ec 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / edc43a9
          Default Java 1.7.0_91
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
          unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt https://builds.apache.org/job/PreCommit-YARN-Build/10327/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10327/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs-httpfs hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: .
          Max memory used 76MB
          Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/10327/console

          This message was automatically generated.

          cheersyang Weiwei Yang added a comment -

          Trigger a new jenkins job. Those failures were not caused by this patch, most of them are timeouts.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
          0 mvndep 0m 58s Maven dependency ordering for branch
          +1 mvninstall 8m 47s trunk passed
          +1 compile 6m 43s trunk passed with JDK v1.8.0_66
          +1 compile 7m 38s trunk passed with JDK v1.7.0_91
          +1 checkstyle 1m 10s trunk passed
          +1 mvnsite 1m 37s trunk passed
          +1 mvneclipse 0m 53s trunk passed
          +1 findbugs 2m 41s trunk passed
          +1 javadoc 1m 3s trunk passed with JDK v1.8.0_66
          +1 javadoc 1m 10s trunk passed with JDK v1.7.0_91
          0 mvndep 0m 31s Maven dependency ordering for patch
          +1 mvninstall 1m 17s the patch passed
          +1 compile 7m 29s the patch passed with JDK v1.8.0_66
          +1 javac 7m 29s the patch passed
          +1 compile 7m 31s the patch passed with JDK v1.7.0_91
          +1 javac 7m 31s the patch passed
          +1 checkstyle 0m 58s the patch passed
          +1 mvnsite 1m 24s the patch passed
          +1 mvneclipse 0m 43s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 53s the patch passed
          +1 javadoc 0m 51s the patch passed with JDK v1.8.0_66
          +1 javadoc 1m 4s the patch passed with JDK v1.7.0_91
          -1 unit 65m 28s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.8.0_66.
          -1 unit 64m 20s hadoop-yarn-client in the patch failed with JDK v1.8.0_66.
          -1 unit 64m 23s hadoop-yarn-client in the patch failed with JDK v1.8.0_66.
          -1 unit 66m 32s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.7.0_91.
          -1 unit 64m 31s hadoop-yarn-client in the patch failed with JDK v1.7.0_91.
          -1 unit 64m 34s hadoop-yarn-client in the patch failed with JDK v1.7.0_91.
          +1 asflicense 0m 34s Patch does not generate ASF License warnings.
          449m 32s



          Reason Tests
          JDK v1.8.0_66 Failed junit tests hadoop.yarn.server.resourcemanager.TestClientRMTokens
            hadoop.yarn.server.resourcemanager.TestAMAuthorization
            hadoop.yarn.client.TestGetGroups
            hadoop.yarn.client.TestGetGroups
          JDK v1.8.0_66 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient
            org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient
          JDK v1.7.0_91 Failed junit tests hadoop.yarn.server.resourcemanager.TestClientRMTokens
            hadoop.yarn.server.resourcemanager.TestAMAuthorization
            hadoop.yarn.client.api.impl.TestAMRMClientOnRMRestart
            hadoop.yarn.client.TestGetGroups
            hadoop.yarn.client.api.impl.TestAMRMClientOnRMRestart
            hadoop.yarn.client.TestGetGroups
          JDK v1.7.0_91 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient
            org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12783263/YARN-4605.002.patch
          JIRA Issue YARN-4605
          Optional Tests asflicense mvnsite compile javac javadoc mvninstall unit findbugs checkstyle
          uname Linux 27a29959dd21 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 1acc509
          Default Java 1.7.0_91
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
          unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt https://builds.apache.org/job/PreCommit-YARN-Build/10335/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10335/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs-httpfs hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: .
          Max memory used 77MB
          Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/10335/console

          This message was automatically generated.

          cheersyang Weiwei Yang added a comment -

          All the test failures are not related to this patch. This patch only fixes some typos, nothing functional. Please kindly help to review.
          TestAMAuthorization is tracked via YARN-4318
          TestClientRMTokens is tracked via YARN-4306
          TestGEtGroups is tracked via YARN-4351
          See more in YARN-4478

          ajisakaa Akira Ajisaka added a comment -

          Thanks Weiwei Yang for fixing typos. The patch modifies HDFS source code, so would you create a separate jira in HDFS and separate the patch into HDFS-side and YARN-side?

          cheersyang Weiwei Yang added a comment -

          Exclude changes in HDFS project, patch 003 only contains typo fixes for YARN project.

          cheersyang Weiwei Yang added a comment -

          Hello Akira Ajisaka

          Thanks for the suggestion. I exclude HDFS changes from this patch, opened HDFS-9682 for that. Could you please help to review and commit this ? Thanks a lot.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
          0 mvndep 0m 25s Maven dependency ordering for branch
          +1 mvninstall 8m 22s trunk passed
          +1 compile 2m 6s trunk passed with JDK v1.8.0_66
          +1 compile 2m 29s trunk passed with JDK v1.7.0_91
          +1 checkstyle 0m 31s trunk passed
          +1 mvnsite 1m 7s trunk passed
          +1 mvneclipse 0m 30s trunk passed
          +1 findbugs 1m 56s trunk passed
          +1 javadoc 0m 41s trunk passed with JDK v1.8.0_66
          +1 javadoc 0m 49s trunk passed with JDK v1.7.0_91
          0 mvndep 0m 19s Maven dependency ordering for patch
          +1 mvninstall 0m 59s the patch passed
          +1 compile 2m 23s the patch passed with JDK v1.8.0_66
          +1 javac 2m 23s the patch passed
          +1 compile 2m 27s the patch passed with JDK v1.7.0_91
          +1 javac 2m 27s the patch passed
          +1 checkstyle 0m 32s the patch passed
          +1 mvnsite 1m 3s the patch passed
          +1 mvneclipse 0m 24s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 7s the patch passed
          +1 javadoc 0m 31s the patch passed with JDK v1.8.0_66
          +1 javadoc 0m 39s the patch passed with JDK v1.7.0_91
          -1 unit 60m 55s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.8.0_66.
          -1 unit 64m 18s hadoop-yarn-client in the patch failed with JDK v1.8.0_66.
          -1 unit 62m 20s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.7.0_91.
          -1 unit 64m 33s hadoop-yarn-client in the patch failed with JDK v1.7.0_91.
          +1 asflicense 0m 18s Patch does not generate ASF License warnings.
          284m 5s



          Reason Tests
          JDK v1.8.0_66 Failed junit tests hadoop.yarn.server.resourcemanager.TestClientRMTokens
            hadoop.yarn.server.resourcemanager.scheduler.fair.TestFairScheduler
            hadoop.yarn.server.resourcemanager.TestAMAuthorization
            hadoop.yarn.client.TestGetGroups
          JDK v1.8.0_66 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient
          JDK v1.7.0_91 Failed junit tests hadoop.yarn.server.resourcemanager.TestClientRMTokens
            hadoop.yarn.server.resourcemanager.TestAMAuthorization
            hadoop.yarn.client.TestGetGroups
          JDK v1.7.0_91 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
            org.apache.hadoop.yarn.client.api.impl.TestYarnClient
            org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
            org.apache.hadoop.yarn.client.api.impl.TestNMClient



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12783738/YARN-4605.003.patch
          JIRA Issue YARN-4605
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 01bd6556b627 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / ae9c61f
          Default Java 1.7.0_91
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10365/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10365/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10365/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10365/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
          unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10365/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10365/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10365/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt https://builds.apache.org/job/PreCommit-YARN-Build/10365/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10365/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: hadoop-yarn-project/hadoop-yarn
          Max memory used 77MB
          Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/10365/console

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          +1, committing this. I ran all the failed tests locally and they passed.

          cheersyang Weiwei Yang added a comment -

          Thanks a lot Akira Ajisaka. Yes those UT failures are not related. YARN-4478 tracks all UT failures.

          ajisakaa Akira Ajisaka added a comment -

          Committed this to trunk, branch-2, and branch-2.8. Thanks Weiwei Yang for the contribution!

          cheersyang Weiwei Yang added a comment -

          Thank you Akira Ajisaka

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #9163 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9163/)
          YARN-4605. Spelling mistake in the help message of "yarn (aajisaka: rev 8f58f742aea87b2b46b9741ffeaebfa36af3573f)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/cli/TestYarnCLI.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ClientRMService.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/ApplicationCLI.java
          • hadoop-yarn-project/CHANGES.txt
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestClientRMService.java

            People

            • Assignee:
              cheersyang Weiwei Yang
              Reporter:
              mballur Manjunath Ballur
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development