Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: nodemanager
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      TestNodeStatusUpdater.testStopReentrant:1269 expected:<0> but was:<1>

      https://github.com/apache/hadoop/blob/4ac6799d4a8b071e0d367c2d709e84d8ea06942d/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/TestNodeStatusUpdater.java#L1269

      The corresponding JUnit assertion code is:

      Assert.assertEquals(numCleanups.get(), 1);

      It seems that the 1st arg and the 2nd one should be swapped.

      1. 0001-YARN-4543.patch
        1 kB
        Rohith Sharma K S
      2. YARN-4543-1.patch
        2 kB
        Akihiro Suda

        Issue Links

          Activity

          suda Akihiro Suda added a comment -

          Attached YARN-4543-1.patch.
          As with YARN-4548, I verified the patch using my tool that makes a noise to thread interleaving: https://github.com/AkihiroSuda/MicroEarthquake/tree/4367ec9d098c8943e87933e473f8206aecbd63b0

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 7m 40s trunk passed
          +1 compile 0m 25s trunk passed with JDK v1.8.0_66
          +1 compile 0m 28s trunk passed with JDK v1.7.0_91
          +1 checkstyle 0m 11s trunk passed
          +1 mvnsite 0m 29s trunk passed
          +1 mvneclipse 0m 13s trunk passed
          +1 findbugs 0m 56s trunk passed
          +1 javadoc 0m 19s trunk passed with JDK v1.8.0_66
          +1 javadoc 0m 22s trunk passed with JDK v1.7.0_91
          +1 mvninstall 0m 25s the patch passed
          +1 compile 0m 23s the patch passed with JDK v1.8.0_66
          +1 javac 0m 23s the patch passed
          +1 compile 0m 25s the patch passed with JDK v1.7.0_91
          +1 javac 0m 25s the patch passed
          +1 checkstyle 0m 12s the patch passed
          +1 mvnsite 0m 27s the patch passed
          +1 mvneclipse 0m 10s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 2s the patch passed
          +1 javadoc 0m 16s the patch passed with JDK v1.8.0_66
          +1 javadoc 0m 19s the patch passed with JDK v1.7.0_91
          +1 unit 8m 39s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.8.0_66.
          +1 unit 9m 6s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.7.0_91.
          +1 asflicense 0m 17s Patch does not generate ASF License warnings.
          33m 58s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12780942/YARN-4543-1.patch
          JIRA Issue YARN-4543
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 47fa27803a8c 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 6702e7d
          Default Java 1.7.0_91
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
          findbugs v3.0.0
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10186/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
          Max memory used 76MB
          Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/10186/console

          This message was automatically generated.

          rohithsharma Rohith Sharma K S added a comment -

          +1 committing in. I reproduced the issue and applied the patch and ran again. Test cases passes.

          The reason for test failure is, AbstractService#stop first switch service state to STOPPED and start stopping all the registered services. So even after nm.getServiceState() is STOPPED, internally registered services stop takes few seconds. But in the test, before all services get stopped, only checking for nm.getServiceState does not help. So , need to wait for few seconds more.

          rohithsharma Rohith Sharma K S added a comment -

          patch need to be rebased. updating myself since it small change.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 10m 40s trunk passed
          +1 compile 0m 49s trunk passed with JDK v1.8.0_66
          +1 compile 0m 38s trunk passed with JDK v1.7.0_91
          +1 checkstyle 0m 19s trunk passed
          +1 mvnsite 0m 42s trunk passed
          +1 mvneclipse 0m 17s trunk passed
          +1 findbugs 1m 26s trunk passed
          +1 javadoc 0m 37s trunk passed with JDK v1.8.0_66
          +1 javadoc 0m 31s trunk passed with JDK v1.7.0_91
          +1 mvninstall 0m 39s the patch passed
          +1 compile 0m 46s the patch passed with JDK v1.8.0_66
          +1 javac 0m 46s the patch passed
          +1 compile 0m 33s the patch passed with JDK v1.7.0_91
          +1 javac 0m 33s the patch passed
          +1 checkstyle 0m 18s the patch passed
          +1 mvnsite 0m 37s the patch passed
          +1 mvneclipse 0m 15s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 42s the patch passed
          +1 javadoc 0m 34s the patch passed with JDK v1.8.0_66
          +1 javadoc 0m 27s the patch passed with JDK v1.7.0_91
          -1 unit 11m 14s hadoop-yarn-server-nodemanager in the patch failed with JDK v1.8.0_66.
          -1 unit 10m 30s hadoop-yarn-server-nodemanager in the patch failed with JDK v1.7.0_91.
          +1 asflicense 0m 25s Patch does not generate ASF License warnings.
          45m 35s



          Reason Tests
          JDK v1.7.0_91 Failed junit tests hadoop.yarn.server.nodemanager.TestNodeManagerResync
            hadoop.yarn.server.nodemanager.containermanager.logaggregation.TestLogAggregationService



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12785094/0001-YARN-4543.patch
          JIRA Issue YARN-4543
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 26aa8e7b5790 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / f67149a
          Default Java 1.7.0_91
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10430/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-YARN-Build/10430/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.7.0_91.txt
          unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10430/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10430/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
          Max memory used 76MB
          Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/10430/console

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          +1

          rohithsharma Rohith Sharma K S added a comment -

          committed to trunk/branch-2.. thanks Akihiro Suda for the patch!! thanks Akira Ajisaka for additional review..

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #9206 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9206/)
          YARN-4543. Fix random test failure in (rohithsharmaks: rev ac686668031ee9837deed3f3566f09f33c437870)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/TestNodeStatusUpdater.java
          • hadoop-yarn-project/CHANGES.txt
          suda Akihiro Suda added a comment -

          Rohith Sharma K S, Akira Ajisaka Thank you for reviewing, rebasing, and merging!

          jlowe Jason Lowe added a comment -

          Thanks Akihiro Suda! I committed this to branch-2.8 as well.


            People

            • Assignee:
              suda Akihiro Suda
              Reporter:
              suda Akihiro Suda
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development