Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-321 [Umbrella] Generic application history service
  3. YARN-2542

"yarn application -status <appId>" throws NPE when retrieving the app from the timelineserver

Log workAgile BoardRank to TopRank to BottomAttach filesAttach ScreenshotBulk Copy AttachmentsBulk Move AttachmentsVotersWatch issueWatchersConvert to IssueMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Sub-task
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 2.6.0
    • None
    • None
    • Reviewed

    Description

      "yarn application -status <appId>" throws NPE when retrieving the app from the timelineserver. It's broken by YARN-415. When app is finished, there's no usageReport.

      Attachments

        1. YARN-2542.4.patch
          6 kB
          Jian He
        2. YARN-2542.3.patch
          6 kB
          Jian He
        3. YARN-2542.2.patch
          6 kB
          Zhijie Shen
        4. YARN-2542.1.patch
          6 kB
          Zhijie Shen

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            zjshen Zhijie Shen Assign to me
            zjshen Zhijie Shen
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment