Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-2421

RM still allocates containers to an app in the FINISHING state

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: scheduler
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      I saw an instance of a bad application master where it unregistered with the RM but then continued to call into allocate. The RMAppAttempt went to the FINISHING state, but the capacity scheduler kept allocating it containers. We should probably have the capacity scheduler check that the application isn't in one of the terminal states before giving it containers.

      1. YARN-2421.4.patch
        4 kB
        Chang Li
      2. YARN-2421.5.patch
        4 kB
        Chang Li
      3. YARN-2421.6.patch
        5 kB
        Chang Li
      4. YARN-2421.7.patch
        5 kB
        Chang Li
      5. YARN-2421.8.patch
        6 kB
        Chang Li
      6. YARN-2421.9.patch
        6 kB
        Chang Li
      7. yarn2421.patch
        6 kB
        Chang Li
      8. yarn2421.patch
        5 kB
        Chang Li
      9. yarn2421.patch
        5 kB
        Chang Li

        Activity

        airbots Chen He added a comment -

        Chang Li, is this "+ System.out.println("xxx inside test");" your debug code? If so, remove it from patch.

        lichangleo Chang Li added a comment -

        updated patch

        lichangleo Chang Li added a comment -

        Chen He, Have removed that, thanks for finding that out

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12663498/yarn2421.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        -1 release audit. The applied patch generated 3 release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-YARN-Build/4693//testReport/
        Release audit warnings: https://builds.apache.org/job/PreCommit-YARN-Build/4693//artifact/trunk/patchprocess/patchReleaseAuditProblems.txt
        Console output: https://builds.apache.org/job/PreCommit-YARN-Build/4693//console

        This message is automatically generated.

        lichangleo Chang Li added a comment -

        updated patch with apache license header

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12663584/yarn2421.patch
        against trunk revision 20625c8.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        -1 javac. The applied patch generated 1215 javac compiler warnings (more than the trunk's current 1214 warnings).

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager:

        org.apache.hadoop.yarn.server.resourcemanager.TestMoveApplication
        org.apache.hadoop.yarn.server.resourcemanager.rmcontainer.TestRMContainerImpl
        org.apache.hadoop.yarn.server.resourcemanager.scheduler.fair.TestFairScheduler

        Test results: https://builds.apache.org/job/PreCommit-YARN-Build/6280//testReport/
        Javac warnings: https://builds.apache.org/job/PreCommit-YARN-Build/6280//artifact/patchprocess/diffJavacWarnings.txt
        Console output: https://builds.apache.org/job/PreCommit-YARN-Build/6280//console

        This message is automatically generated.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12663584/yarn2421.patch
        against trunk revision af9d4fe.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        -1 javac. The applied patch generated 1147 javac compiler warnings (more than the trunk's current 1146 warnings).

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager:

        org.apache.hadoop.yarn.server.resourcemanager.rmcontainer.TestRMContainerImpl

        Test results: https://builds.apache.org/job/PreCommit-YARN-Build/7287//testReport/
        Javac warnings: https://builds.apache.org/job/PreCommit-YARN-Build/7287//artifact/patchprocess/diffJavacWarnings.txt
        Console output: https://builds.apache.org/job/PreCommit-YARN-Build/7287//console

        This message is automatically generated.

        cwelch Craig Welch added a comment -

        Hi Chang Li, thanks for working on this fix. Can you resolve the javac warning and run the TestRMContainerImpl test locally with the patch to verify the patch is not the cause? It seems to be persistently failing.

        vinodkv Vinod Kumar Vavilapalli added a comment -

        AMs also are expected to keep unregistering after the initial unregister so as to handle things like state-store persistence of the final-state. Your patch will start throwing exceptions to the AMs while the final state is being persisted. /cc Jian He

        I think a simpler solution is to simply let in and ignore all the allocate requests once the apps reaches the FINAL_SAVING state.

        lichangleo Chang Li added a comment -

        Thanks for suggestions! I am planning to come back to work on this issue soon.

        lichangleo Chang Li added a comment -

        updated my patch, the current approach ignores allocate requests when app attempt is in final_saving, finishing or isAppFinalStateStored

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 39s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 34s There were no new javac warning messages.
        +1 javadoc 9m 33s There were no new javadoc warning messages.
        +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
        -1 checkstyle 0m 51s The applied patch generated 2 new checkstyle issues (total was 30, now 31).
        -1 whitespace 0m 0s The patch has 1 line(s) that end in whitespace. Use git apply --whitespace=fix.
        +1 install 1m 34s mvn install still works.
        +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
        +1 findbugs 1m 14s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 yarn tests 52m 19s Tests passed in hadoop-yarn-server-resourcemanager.
            88m 41s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12731296/YARN-2421.4.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 4d9f9e5
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/7785/artifact/patchprocess/diffcheckstylehadoop-yarn-server-resourcemanager.txt
        whitespace https://builds.apache.org/job/PreCommit-YARN-Build/7785/artifact/patchprocess/whitespace.txt
        hadoop-yarn-server-resourcemanager test log https://builds.apache.org/job/PreCommit-YARN-Build/7785/artifact/patchprocess/testrun_hadoop-yarn-server-resourcemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/7785/testReport/
        Java 1.7.0_55
        uname Linux asf902.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/7785/console

        This message was automatically generated.

        hadoopqa Hadoop QA added a comment -



        +1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 37s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 30s There were no new javac warning messages.
        +1 javadoc 9m 31s There were no new javadoc warning messages.
        +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
        +1 checkstyle 0m 26s There were no new checkstyle issues.
        +1 whitespace 0m 1s The patch has no lines that end in whitespace.
        +1 install 1m 37s mvn install still works.
        +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
        +1 findbugs 1m 14s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 yarn tests 52m 20s Tests passed in hadoop-yarn-server-resourcemanager.
            88m 15s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12731475/YARN-2421.5.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 3cefc02
        hadoop-yarn-server-resourcemanager test log https://builds.apache.org/job/PreCommit-YARN-Build/7815/artifact/patchprocess/testrun_hadoop-yarn-server-resourcemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/7815/testReport/
        Java 1.7.0_55
        uname Linux asf906.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/7815/console

        This message was automatically generated.

        lichangleo Chang Li added a comment -

        Craig Welch, Vinod Kumar Vavilapalli, Jason Lowe could you help review this patch. Thanks

        jlowe Jason Lowe added a comment -
        +        AllocateResponse allocateResponse =
        +                recordFactory.newRecordInstance(AllocateResponse.class);
        +        return allocateResponse;
        

        Nit: This should use AllocateResponse.newInstance instead of recordFactory.

        We probably shouldn't be returning a truly empty allocate response record. Callers will get null for many fields they try to lookup like available resources. Ideally they should be protected from that, but I suspect many will not be. We should provide an empty list of containers, a headroom of zero resources, etc. Something a bit more helpful than a bunch of nulls.

        Another possible approach rather than short-circuiting the complete AllocateResponse message is to short-circuit the scheduler.allocate call with a canned Allocation. Then we can let the rest of the code work with that bogus Allocation and the app can continue to be updated on node health, AMRM token updates, etc.

        lichangleo Chang Li added a comment -

        Thanks Jason Lowe for review! have updated my patch according to your suggestion. Let me know if you have other concerns. Thanks!

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 38s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 35s There were no new javac warning messages.
        +1 javadoc 9m 41s There were no new javadoc warning messages.
        +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
        -1 checkstyle 0m 46s The applied patch generated 2 new checkstyle issues (total was 30, now 31).
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 33s mvn install still works.
        +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
        +1 findbugs 1m 14s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 yarn tests 52m 11s Tests passed in hadoop-yarn-server-resourcemanager.
            88m 37s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12732346/YARN-2421.6.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / f24452d
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/7900/artifact/patchprocess/diffcheckstylehadoop-yarn-server-resourcemanager.txt
        hadoop-yarn-server-resourcemanager test log https://builds.apache.org/job/PreCommit-YARN-Build/7900/artifact/patchprocess/testrun_hadoop-yarn-server-resourcemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/7900/testReport/
        Java 1.7.0_55
        uname Linux asf909.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/7900/console

        This message was automatically generated.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 15m 3s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 47s There were no new javac warning messages.
        +1 javadoc 9m 59s There were no new javadoc warning messages.
        +1 release audit 0m 23s The applied patch does not increase the total number of release audit warnings.
        -1 checkstyle 0m 47s The applied patch generated 1 new checkstyle issues (total was 30, now 30).
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 34s mvn install still works.
        +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
        +1 findbugs 1m 17s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 yarn tests 52m 27s Tests passed in hadoop-yarn-server-resourcemanager.
            89m 53s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12732391/YARN-2421.7.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / f24452d
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/7906/artifact/patchprocess/diffcheckstylehadoop-yarn-server-resourcemanager.txt
        hadoop-yarn-server-resourcemanager test log https://builds.apache.org/job/PreCommit-YARN-Build/7906/artifact/patchprocess/testrun_hadoop-yarn-server-resourcemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/7906/testReport/
        Java 1.7.0_55
        uname Linux asf903.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/7906/console

        This message was automatically generated.

        lichangleo Chang Li added a comment -

        The check style is not related to my change. Jason Lowe could you help review the latest patch. Thanks!

        jlowe Jason Lowe added a comment -

        Thanks for updating the patch, Chang! It's looking much better, and all that is left now are mostly nits.

        The stubbed allocation should be constant like EMPTY_ALLOCATION in AbstractYarnScheduler. There's no need to construct the exact same object each time we need it.

        For improved readability it'd be nice to have a line between the new unit test and the test before it.

        The new unit test should be named a bit more specifically than just "bad allocation." Something like testAllocateAfterUnregister since that's literally what the test is doing.

        Could you elaborate on why the sleep(1000) is needed? In general we want to avoid any unnecessary sleeps, as our unit tests take too long as it is already. Should we be draining a dispatcher instead?

        hadoopqa Hadoop QA added a comment -



        +1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 41s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 35s There were no new javac warning messages.
        +1 javadoc 9m 35s There were no new javadoc warning messages.
        +1 release audit 0m 23s The applied patch does not increase the total number of release audit warnings.
        +1 checkstyle 0m 23s There were no new checkstyle issues.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 36s mvn install still works.
        +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
        +1 findbugs 1m 16s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 yarn tests 49m 56s Tests passed in hadoop-yarn-server-resourcemanager.
            86m 0s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12732938/YARN-2421.9.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 15ccd96
        hadoop-yarn-server-resourcemanager test log https://builds.apache.org/job/PreCommit-YARN-Build/7939/artifact/patchprocess/testrun_hadoop-yarn-server-resourcemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/7939/testReport/
        Java 1.7.0_55
        uname Linux asf905.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/7939/console

        This message was automatically generated.

        lichangleo Chang Li added a comment -

        Thanks Jason Lowe for valuable feedback! have updated my patch according to those suggestions. Could you please help review the latest patch. Thanks!

        jlowe Jason Lowe added a comment -

        +1 latest patch lgtm. Committing this.

        jlowe Jason Lowe added a comment -

        Thanks, Chang! I committed this to trunk and branch-2.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #7842 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7842/)
        YARN-2421. RM still allocates containers to an app in the FINISHING state. Contributed by Chang Li (jlowe: rev f7e051c4310024d4040ad466c34432c72e88b0fc)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ApplicationMasterService.java
        • hadoop-yarn-project/CHANGES.txt
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestApplicationMasterService.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #198 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/198/)
        YARN-2421. RM still allocates containers to an app in the FINISHING state. Contributed by Chang Li (jlowe: rev f7e051c4310024d4040ad466c34432c72e88b0fc)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestApplicationMasterService.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ApplicationMasterService.java
        • hadoop-yarn-project/CHANGES.txt
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #929 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/929/)
        YARN-2421. RM still allocates containers to an app in the FINISHING state. Contributed by Chang Li (jlowe: rev f7e051c4310024d4040ad466c34432c72e88b0fc)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ApplicationMasterService.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestApplicationMasterService.java
        • hadoop-yarn-project/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2127 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2127/)
        YARN-2421. RM still allocates containers to an app in the FINISHING state. Contributed by Chang Li (jlowe: rev f7e051c4310024d4040ad466c34432c72e88b0fc)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestApplicationMasterService.java
        • hadoop-yarn-project/CHANGES.txt
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ApplicationMasterService.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #187 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/187/)
        YARN-2421. RM still allocates containers to an app in the FINISHING state. Contributed by Chang Li (jlowe: rev f7e051c4310024d4040ad466c34432c72e88b0fc)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestApplicationMasterService.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ApplicationMasterService.java
        • hadoop-yarn-project/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #197 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/197/)
        YARN-2421. RM still allocates containers to an app in the FINISHING state. Contributed by Chang Li (jlowe: rev f7e051c4310024d4040ad466c34432c72e88b0fc)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ApplicationMasterService.java
        • hadoop-yarn-project/CHANGES.txt
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestApplicationMasterService.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Mapreduce-trunk #2145 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2145/)
        YARN-2421. RM still allocates containers to an app in the FINISHING state. Contributed by Chang Li (jlowe: rev f7e051c4310024d4040ad466c34432c72e88b0fc)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ApplicationMasterService.java
        • hadoop-yarn-project/CHANGES.txt
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestApplicationMasterService.java

          People

          • Assignee:
            lichangleo Chang Li
            Reporter:
            tgraves Thomas Graves
          • Votes:
            0 Vote for this issue
            Watchers:
            15 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development