Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-240

Rename ProcessTree.isSetsidAvailable

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: trunk-win
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The logical use of this member is to find out if processes can be grouped into a unit for process manipulation. eg. killing process groups etc.
      setsid is the Linux implementation and it leaks into the name.
      I suggest renaming it to isProcessGroupAvailable.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                bikassaha Bikas Saha
                Reporter:
                bikassaha Bikas Saha
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: