Uploaded image for project: 'XWork'
  1. XWork
  2. XW-822

Incorrect configuration of maven-shade-plugin

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      In xwork-core/pom.xml, maven-shade-plugin is configured as follows:

      <relocations>
      <relocation>
      <pattern>org.objectweb.asm</pattern>
      <shadedPattern>org.objectweb.asm.xwork</shadedPattern>
      </relocation>
      <relocation>
      <pattern>org.apache.commons.lang</pattern>
      <shadedPattern>org.apache.commons.lang.xwork</shadedPattern>
      </relocation>
      <relocation>
      <pattern>org.apache.commons.lang</pattern>
      <shadedPattern>org.apache.commons.io.xwork</shadedPattern>
      </relocation>
      </relocations>

      org.objectweb.asm.xwork and org.apache.commons.io.xwork are never referenced in the source. Good thing, too, since the pattern for common.io is commons.lang!

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jafl5272 John Lindal
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: