XWork
  1. XWork
  2. XW-37

DefaultComponentManager needs to implement Serializable

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-beta1
    • Fix Version/s: 1.0-beta1
    • Component/s: Interceptors
    • Labels:
      None
    • Environment:
      Tomcat 4.1.24

      Description

      WW-166 reports an exception when using Tomcat. It's caused when a serialized session is restored by Tomcat. DefaultComponentManager information is lost. Making it Serializable solves the problem.

        Activity

        Patrick Lightbody added a comment -

        ComponentManager was also extending Serializable, but I removed that and left DCM as implementing Serializable instead.

        Tracy Snell added a comment -

        Should've been clear when I created the issue. I've been running with it implemented on my box since Heng pointed it out to me. Works fine.

        Jason Carreira added a comment -

        DefaultComponentManager now implements Serializable... Can someone else verify that this fixes the problem?

        Tracy Snell added a comment -

        Philipp Meier had a good question on the list:

        "Just to be curious, is this a Tomcat bug or is it necessary or advisable that
        everything put in a HttpSession implements Serializable. I had a quick
        look in the Servlet spec but I is still unclear to me."

        I'm unsure. My initial thoughts were that it was a Tomcat bug. However, there has been a report of the same problem on WebLogic. Doesn't mean it's not a bug in both but may be one we need to work around. Are there drawbacks to having DefaultComponentManager implement Serializable?


          People

          • Assignee:
            Patrick Lightbody
            Reporter:
            Tracy Snell
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development