Uploaded image for project: 'XMLBeans'
  1. XMLBeans
  2. XMLBEANS-123

sfactor fails because it doesn't set classpath fully

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Version 2 Beta 1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP

      Description

      1. Install XMLBeans v2 beta
      2. Try to run sfactor against a schema.
      3. Note the following in the console:
      Using output directory 'out'
      Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/stream/XMLStreamException
      at java.lang.Class.getDeclaredMethods0(Native Method)
      at java.lang.Class.privateGetDeclaredMethods(Class.java:2365)
      at java.lang.Class.getMethod0(Class.java:2611)
      at java.lang.Class.getMethod(Class.java:1579)
      at org.apache.xmlbeans.XmlBeans.buildMethod(XmlBeans.java:174)
      at org.apache.xmlbeans.XmlBeans.buildNodeMethod(XmlBeans.java:195)
      at org.apache.xmlbeans.XmlBeans.buildNodeToCursorMethod(XmlBeans.java:232)
      at org.apache.xmlbeans.XmlBeans.<clinit>(XmlBeans.java:131)
      at org.apache.xmlbeans.impl.xb.xsdschema.SchemaDocument$Factory.parse(SchemaDocument.java:764)
      at org.apache.xmlbeans.impl.tool.FactorImports.main(FactorImports.java:145)

      4. Open bin/sfactor or bin/sfactor.cmd and note that classpath is set to include only xbean.jar. Should probably also include jsr173_api.jar.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              straut Steve Traut
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: