Uploaded image for project: 'XBean'
  1. XBean
  2. XBEAN-287

OSGi metadata should include Spring 4.X as a valid version

Attach filesAttach ScreenshotAdd voteVotersStop watchingWatchersCreate sub-taskConvert to sub-taskLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: 3.16
    • Fix Version/s: None
    • Component/s: spring
    • Flags:
      Patch

      Description

      Spring 4.X is available as OSGi bundles from Apache ServiceMix and since I believe that XBean is compatible with Spring 4, it should be included in the OSGi Import-Package directive.

      I have submitted this change as a pull request to the Geronimo XBean github mirror: https://github.com/apache/geronimo-xbean/pull/11

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              soleger Seth Leger

              Dates

              • Created:
                Updated:

                Issue deployment