Uploaded image for project: 'XalanC'
  1. XalanC
  2. XALANC-772

Building Xalan & xerces on Oracle Linux 6.6 & Compiler solarisstudio12.3 C++ compiler for Linux



    • Type: Task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Implemented
    • Affects Version/s: 1.10
    • Fix Version/s: 1.11
    • Component/s: XalanC
    • Labels:
    • Environment:
      Platform:- Oracle Linux 6.6
      Compiler :- solarisstudio12.3 C++ compiler for Linux
    • Flags:


      Hi Team,

      I am facing issue while using Xalan & Xerces for my application.
      Below are my environment details i am using :-
      Platform:- Oracle Linux 6.6
      Compiler :- solarisstudio12.3 C++ compiler for Linux

      Below are the versions of Xalan & Xerces source code used to build the shared object downloaded from Apache site:-


      Problem Description:-
      I had to build 32 bit shared object which can be used in my application. so i tried building xerces with the options for my platform as :-
      ./runConfigure -plinux -ccc -xCC
      i added -m32 falg in makefile and it got compiled and created a shared object.
      Then i tried to configure xalan with below command :-
      ./runConfigure -plinux -ccc -xCC
      I tried to compile it but it resulted me in lot of errors. i tried fixing them in order to change compiler and platform defines header files and some make files.
      Finally i was able to create 32 bit shared object for xalan.
      I then tried to use in my application but it was throwing coredump at function XalanMemMgrs::getDefaultXercesMemMgr().
      Below is the code sniplet for the issue :-

      MemoryManagerType* ptr = XMLPlatformUtils::fgMemoryManager;

      assert (ptr != 0);

      return *ptr;
      (dbx:getDefaultXercesMemMgr) display XMLPlatformUtils
      dbx: "XMLPlatformUtils" is not defined in the scope `libxalan-c.so.110`XalanMemoryManagement.cpp`xalanc_1_10::XalanMemMgrs::getDefaultXercesMemMgr()`
      dbx: see `help scope' for details
      (dbx:getDefaultXercesMemMgr) n
      t@4079109952 (l@21431) stopped in xalanc_1_10::XalanMemMgrs::getDefaultXercesMemMgr at line 73 in file "XalanMemoryManagement.cpp"
      73 assert (ptr != 0);

      The value of ptr is showing as nil.

      Need your urgent help in order to understand the changes for my platform requirement and how to sort this memory related issue


          Issue Links



              • Assignee:
                shathaway Steven J. Hathaway
                agrachirag Chirag Agrawal
              • Votes:
                0 Vote for this issue
                1 Start watching this issue


                • Created: