There is a problem with the definition of the underlying class on this HP platform. Plus, I believe we can expand the use of this macro, so we should move it to a more general location.
This patch moves the definition of this macro to PlatformDefinitions.hpp for the time being. If the number of compile-time asserts we use grows, we can move these to a separate file. Also, I've written it in such a way that it compiles out on release builds, although I'm not sure if that's the right thing to do.
Committers, can you please review the patch?