Uploaded image for project: 'Struts 2'
  1. Struts 2
  2. WW-4665

Struts2 JSR286 Portlet fileupload not working

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.3.20
    • Fix Version/s: 2.5.12
    • Component/s: Core Interceptors
    • Labels:
      None
    • Environment:

      OpenPortal portlet container
      Websphere App Server 8.5
      JDK 1.6
      Windows 7

      Description

      Hi Team,

      While using <s:file> struts2 tag in a JSP within a struts2 JSR 286 portlet project, the file related parameters are being received as null inside Action class on submitting the form.

        Activity

        javaapassion JavaaPassion added a comment -

        Hi
        Any quick help would be highly appreciated.

        javaapassion JavaaPassion added a comment - - edited

        Hi Lukasz Lenart,
        Do you mean struts 2.5.3 version is to be tried out ?

        lukaszlenart Lukasz Lenart added a comment -

        Nope, I have marked in which version it must be fixed, just for reference. The problem is that I cannot setup working example locally, without this is hard to investigate what's wrong

        lukaszlenart Lukasz Lenart added a comment -

        I cannot setup local project to test this particular issue, help needed

        yasser.zamani Yasser Zamani added a comment -

        Lukasz Lenart, JavaaPassion, it was hard but finally I created a local project similar to your environment as below:

        • JDK 1.6
        • Struts portlet 2.3.20 JSR286
        • deployed on an OpenPortal portlet container
        • Tomcat 6
        • Windows 8

        for me, fileupload works properly and passes expected parameters to action inside the OpenPortal protlet. I can attach final tomcat including deployed war if you would like to see.

        lukaszlenart Lukasz Lenart added a comment -

        Maybe it was related to other issue with dropping params when exception occurred during upload - this is a know problem in Commons FileUpload library. Anyway thank you for taking care of this issue I think we can close it as "Cannot reproduce"


          People

          • Assignee:
            Unassigned
            Reporter:
            javaapassion JavaaPassion
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development