Uploaded image for project: 'Struts 2'
  1. Struts 2
  2. WW-4349

Missing revision number in struts_dojo.js

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.16.3
    • Fix Version/s: 2.3.20
    • Component/s: Plugin - Dojo Tags
    • Labels:
      None

      Description

      I’ve encountered an issue with the struts dojo plug-in for version 2.3.16.3. The jar file struts2-dojo-plugin-2.3.16.3.jar contains unexpanded source code tags. This is causing an issue in the struts_dojo.js file within the jar e.g.

      Version 2.3.15.2

      struts_dojo.js line 36 :

      dojo.version={major:0,minor:4,patch:3,flag:"",revision:Number("$Rev: 670371 $".match(/[0-9]+/)[0]),toString:function(){
      

      Version 2.3.16.1

      struts_dojo.js line 36 :

      dojo.version={major:0,minor:4,patch:3,flag:"",revision:Number("$Rev$".match(/[0-9]+/)[0]),toString:function(){
      

        Issue Links

          Activity

          mtx Martin Thiim added a comment -

          Hi we encountered this problem when upgrading to Struts2 version 2.3.32. Errors are seen in the browser console when loading dojo.js and dojo.js.uncompressed.js because it doesn't contain the revision number. So I can confirm what Nikos reported in his post, that this was only fixed in the struts_dojo.js.uncompressed .js and struts_dojo.js files, not the dojo.js and dojo.js.uncompressed.js files. I have corrected this manually and repacked the JAR file which solves the issue. However, it would be nicer this was part of the official distribution. So I hereby request reopen the JIRA as suggested by Lukasz It doesn't seem I have permission to reopen it.

          lukaszlenart Lukasz Lenart added a comment -

          Looks like, feel free to re-open

          nikos nikos dimitrakas added a comment -

          Shouldn't this also be fixed in dojo.js and not only in struts_dojo.js?

          hudson Hudson added a comment -

          SUCCESS: Integrated in Struts-JDK6-develop #60 (See https://builds.apache.org/job/Struts-JDK6-develop/60/)
          WW-4349 Fixes problem with dojo.version (lukaszlenart: rev 9944b274e98967d0bff0ec55822b1ca236fc0312)

          • plugins/dojo/src/main/resources/org/apache/struts2/static/dojo/struts_dojo.js
          lukaszlenart Lukasz Lenart added a comment -

          Fixed, thanks!

          jira-bot ASF subversion and git services added a comment -

          Commit 9944b274e98967d0bff0ec55822b1ca236fc0312 in struts's branch refs/heads/develop from Lukasz Lenart
          [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=9944b27 ]

          WW-4349 Fixes problem with dojo.version

          lukaszlenart Lukasz Lenart added a comment -

          You can use file version from 2.3.15.2 - it's due to migration to Git which doesn't support $Rev$ tag. It will be solved in the next version but please be aware that the Dojo Plugin is deprecated and will be dropped with next major release (2.5)


            People

            • Assignee:
              lukaszlenart Lukasz Lenart
              Reporter:
              jhkelly James Kelly
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 24h
                24h
                Remaining:
                Remaining Estimate - 24h
                24h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development