Uploaded image for project: 'Struts 2'
  1. Struts 2
  2. WW-4255

Missing interface org/apache/struts2/views/TagLibrary

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.3.16
    • Fix Version/s: 2.3.20
    • Component/s: None
    • Labels:
      None
    • Environment:

      All

      Description

      I just upgraded from version 2.3.15 to version 2.3.16 and my application no longer starts. We use a plugin that needs following interface: org/apache/struts2/views/TagLibrary

      We now get a NoClassDefFoundError

      Was this removed for a certain reason or not?

      Maybe following stacktrace makes it more clear:

      13:59:11,253 ERROR [Dispatcher] Dispatcher initialization failed
      Unable to load configuration. - bean - vfszip:/C:/server/jboss-5.1.0.GA/server/***/deploy/***.war/WEB-INF/lib/struts2-jquery-plugin-3.6.1.jar/struts-plugin.xml:27:125
      	at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:70)
      	at org.apache.struts2.dispatcher.Dispatcher.init_PreloadConfiguration(Dispatcher.java:445)
      	at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:489)
      	at org.apache.struts2.dispatcher.ng.InitOperations.initDispatcher(InitOperations.java:74)
      	at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.init(StrutsPrepareAndExecuteFilter.java:57)
      
      -- snip --
      
      Caused by: Unable to load bean: type:org.apache.struts2.views.TagLibrary class:com.jgeppert.struts2.jquery.views.JqueryTagLibrary - bean - vfszip:/C:/server/jboss-5.1.0.GA/server/***/deploy/***.war/WEB-INF/lib/struts2-jquery-plugin-3.6.1.jar/struts-plugin.xml:27:125
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.register(XmlConfigurationProvider.java:245)
      	at org.apache.struts2.config.StrutsXmlConfigurationProvider.register(StrutsXmlConfigurationProvider.java:102)
      	at com.opensymphony.xwork2.config.impl.DefaultConfiguration.reloadContainer(DefaultConfiguration.java:234)
      	at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:67)
      	... 71 more
      Caused by: java.lang.NoClassDefFoundError: org/apache/struts2/views/TagLibrary
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
      

        Activity

        hudson Hudson added a comment -

        SUCCESS: Integrated in Struts-JDK6-develop #55 (See https://builds.apache.org/job/Struts-JDK6-develop/55/)
        WW-4255 restores TagLibrary interface and marks it as deprecated (lukaszlenart: rev 9aedd857a4294a5091bce6abcdcb183f83833cb6)

        • core/src/main/java/org/apache/struts2/views/freemarker/FreemarkerManager.java
        • core/src/main/java/org/apache/struts2/views/TagLibrary.java
        • core/src/main/java/org/apache/struts2/views/DefaultTagLibrary.java
        • core/src/main/java/org/apache/struts2/views/velocity/VelocityManager.java
        lukaszlenart Lukasz Lenart added a comment -

        Done, interface restored!

        jira-bot ASF subversion and git services added a comment -

        Commit 9aedd857a4294a5091bce6abcdcb183f83833cb6 in struts's branch refs/heads/develop from Lukasz Lenart
        [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=9aedd85 ]

        WW-4255 restores TagLibrary interface and marks it as deprecated

        lukaszlenart Lukasz Lenart added a comment -

        I'm going restore this interface and mark it as @Deprecated

        tbriers Tom Briers added a comment -

        I actually read the version notes before upgrading so I was quiet surprised. Thanks for the fast response.


          People

          • Assignee:
            lukaszlenart Lukasz Lenart
            Reporter:
            tbriers Tom Briers
          • Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development