Struts 2
  1. Struts 2
  2. WW-3789

Memory leak while undeploying Struts 2 application

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 2.3.3
    • Component/s: None
    • Labels:
      None
    • Environment:

      Tomcat 6.0.26, Struts 2.3.1.2

      Description

      Struts 2.3.1.2 web app running on Tomcat 6.0.26: created a ThreadLocal with key of type [com.opensymphony.xwork2.inject.ContainerImpl$10] (value [com.opensymphony.xwork2.inject.ContainerImpl$10@10769dd]) and a value of type [java.lang.Object[]] (value [[ ...

      Having trouble redeploying .war file on Tomcat, Commons Logging references to ActionMappings are not being garbage collected.

      Looking to redo the application not using Struts.

        Issue Links

          Activity

          Philip Luppens added a comment -

          I've updated this issue to be a little more coherent and lowered the priority since this is not critical. I believe Rene made some changes lately to deal with this exact kind of issues, but I'm not sure if they are already released.

          Can you try a nightly and see if that solves your problem?

          Rene Gielen added a comment -

          This is a duplicate of WW-3768 and is fixed for the soon to be released version 2.3.2

          James O'Hara added a comment -

          I just downloaded struts-2.3.2-SNAPSHOT

          I am still getting errors.
          created a ThreadLocal with key of type [org.apache.log4j.helpers.ThreadLocalMap] (value [org.apache.log4j.helpers.ThreadLocalMap@66da2c]) and a value of type [java.util.Hashtable] (value [

          {userId=jo2372}

          ]) but failed to remove it when the web application was stopped. This is very likely to create a memory leak.

          Might be resolved on your end, but not in the enduser realm.

          Rene Gielen added a comment -

          As your stacktrace says, this is a log4j and not a Struts 2 problem. So far the bad news
          The good news is that this issue is going to be resolved with log4j 1.2.17, which will be out any time soon. It will target more or less exclusively this particular issue.
          See https://issues.apache.org/bugzilla/show_bug.cgi?id=50486

          James O'Hara added a comment -

          Thank you this is good news.


            People

            • Assignee:
              Rene Gielen
              Reporter:
              James O'Hara
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development